
 
 

 

 

 

 

 

 
 

 
User Manual 
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SOFTWARE LICENSE AGREEMENT 
IMPORTANT - READ CAREFULLY 
This is a legal agreement between you (either an individual or a single entity) and Timestone Software. By keeping this 
package and using the software, you are accepting the terms and are bound by the terms of this license. If you do not wish to 
enter into this agreement, please promptly return all copies of the Software, User Guides and Hardlock devices to Timestone 
Software for a full refund. This User Guide and the software programs it describes are protected by copyright, trade secret 
and trademark law. By accepting this license, you have the right to use them, subject to the terms and conditions of this 
license agreement. 

Definitions and Interpretation 

• Software means the Program modules enabled and authorised for use for your installation. 

• Hardlock device means the hardware device used to enable the Software to function. 

• Scope of Agreement 

• Timestone Software hereby grants you, the original purchaser, personal, non-exclusive license to use the User 
Guide and the Software subject to the terms and conditions of this Agreement. 

• Grant of License. You may use the Software on a maximum of one computer that you own or operate at a 
single physical location . You may transfer the Software from one computer to another provided that you do 
not use or permit the usage of the Software on more than one computer or computer terminal at a time. 

• Copies. You may not copy or duplicate the Software, except as necessary solely for archival purposes, 
program error verification, or to replace defective storage media, provided you keep the original and the 
copies. You may not alter, decompile or disassemble the Software. 

• Transfers. You may not sublicense, lease or rent or lend the Software or transfer any of your rights under this 
Agreement. You may transfer the Software (together with any backup copies you have made), Hardlock 
device and the User Guide on a permanent basis so long as you retain no copies, the transferee agrees to be 
bound by the terms of this Agreement, and Timestone Software has authorised the transfer by written 
confirmation. 

• Term. The License granted in this agreement is effective until terminated. You may terminate it at any time by 
destroying or returning to Timestone Software the Software and the User Guide, together with all copies, and 
returning to Timestone Software the Hardlock Device. If you fail to comply with any term or condition of this 
Agreement, this License will terminate and, upon such termination, you agree to destroy or return to 
Timestone Software the Software and the User Guide, together with all copies, and return to Timestone 
Software the Hardlock Device. Termination of this license shall be in addition and not in lieu of any other 
remedies available to Timestone Software. 

Limited Warranty, Disclaimer 
Timestone Software warrants that the media on which the Software is recorded and the User Guide provided with it are free 
from defects in material and workmanship under normal use for a period of 90 days from the date of your original purchase. 
Except for the limited warranty described above, the Software is sold “as is”, and you are assuming the entire risk as to its 
quality and performance. It is your responsibility to verify the results obtained from the use of the Software. 

Limitation of Remedies 
If during the 90-day limited warranty period, you discover physical defects in the User Guide or in the Media on which the 
Software was recorded, Timestone Software will replace them as no charge to you. This is your sole remedy. 

IN NO EVENT WILL TIMESTONE SOFTWARE BE LIABLE TO ANY PERSON FOR ANY DIRECT, 
INDIRECT, SPECIAL, INCIDENTAL, CONSEQUENTIAL OR SIMILAR DAMAGES, EVEN IF TIMESTONE 
SOFTWARE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
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ore you Begin… 

Scope and audience 
This manual covers both operation and technical aspects required to use NeoGroup. The 
manual is divided into several chapters – see the Table of Contents at the start for a broad 
summary.  Alternatively, consult the Index for specific procedures. 

If you’re planning to have multiple users using NeoGroup in a networked environment, 
you’ll need to look at Chapter 4, License Server, for info on how the license system 
works and where to put that hardlock/dongle we sent you! 

Getting more help 
More help is available for NeoGroup from the following places: 

Related documents such as our Color Management Guide and the Bitmap 
Compare Utility Guide. 

! 

! 

! 

! 

! 

! 

! 

! 

Help pages from our WWW site, http://www.timestone.com.au 
Technical support as noted at the end of this chapter 

Pre-installation requirements 
You will need to following resources and information before you start installing 
NeoGroup: 

NeoGroup software installation CD-ROM 
NeoGroup software user’s guide 
Hardware protection device 
‘Unlock’ code supplied by Timestone Software 
Your computer complies with the hardware and software specifications 
as outlined in Chapter 3, Installing NeoGroup. 

Learning NeoGroup 
Included on the NeoGroup CD-ROM are contained the following resources: 
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Installation files ! 

! NeoGroup user manual – the document you are currently reading 

Getting help from Technical Support 
We offer many different methods of support. However, we strongly encourage you to use 
e-mail as your primary support mechanism. 

Telephone support 

! 

☎  Telephone support is available by calling Timestone Software during our business hours. 
These hours are: 

9:00 AM – 5:00 PM Australian Eastern time 

The telephone numbers are: 

Voice: + 61 3 9570 9899 

Fax support 
You can fax us with questions or queries. Please address your fax queries to Technical 
Support. The fax number is: 

Fax: + 61 3 9570 9855 

E-mail and WWW support 
There are support pages that include links to the newest versions of the software, as well 
as user documentation, and ‘Frequently Asked Problems’. 

Our WWW and e-mail contacts are: 

WWW: http://www.timestone.com.au 
E-mail: support@timestone.com.au 
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tem Requirements 

Hardware requirements 
The following hardware requirements are required as a minimum configuration to run 
NeoGroup. You should always attempt to exceed these requirements. 

If you have a choice in areas that you can afford to exceed these requirements – do this in 
the following order: 

Memory ! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

! 

CPU class (Pentium II, Pentium III) 
CPU Speed 
Hard disk speed (Ultra, Ultra Wide, RAID) 
Other 

Minimum requirements 
Intel Pentium II processor at 350 Mhz 
100 Mhz system motherboard (Bx class) 
128 Mb RAM 
4Mb Video card (1024 x 768 @ 24 bit - see note) 
9Gb Hard Disk (see note) 
10 / 100 Ethernet card 
33.6k Modem 
High quality (Sony, Apple) 17" colour monitor 
Windows NT 4.0, Service Pack 3 
Mouse with mouse wheel (Microsoft, Logitec) 

Optional Extras 

6 x 9cm Graphics Tablet with pressure sensitive stylus (Wacom) 
CD-R or DVD RAM drive for data backup 
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Notes 
Video Card: It is most important to use a high quality video card. In particular, you 
should use video cards that support monitor calibration in some manner. Typically, 
manufacturers such as ATI or Video Seven have such products. 

Hard disk: If you are using NeoGroup on a single workstation, you should realise that 
very quickly you will use 9Gb of data storage, just with the images you scan to create your 
products. If your requirements are low volume, you could consider a single 9Gb hard, and 
continually move images that are finished onto a CD-Rom or DVD-RAM disk. However, 
if you are producing just an average number of packages, you will want to use a number 
of drives. Fortunately, hard disk drive costs are relatively low today. 
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talling NeoGroup 

Open the CD-ROM in Windows Explorer or My Computer, and double-click the file, 
Install NeoGroup. The installer 
screen appears. 

The installation process may 
require a restart mid-way through 
the process. If the installer 
requests you to restart the PC, 
please do so, as the installation is 
not able to complete without the 
restart.  

• Choose Next to proceed. 

• Read the contents of the 
ReadMe screen. It contains 
timely information that 
may be required for the 
installation. Choose Next to proceed. 

• Choose the location for the program files to be installed to. Unless you have a 
particular reason for changing the default path setting, we recommend you leave it 
as is.  Choose Next to proceed. 

• Allow the program to create backup files for the installation. Choose Next to 
proceed. 

• Choose the components to 
install. If this machine is 
to house the hardlock, 
install the License Server 
component. 

• Documentation and 
tutorial files are installed 
to the same directory as 
the program files. 

• Choose Next to proceed. 
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• Select the name of the Program Manager group to add the icons to. Choose Next 
to proceed. 

• Once you’re happy with 
all the settings, choose 
Next to proceed, or 
choose Back to change 
any of your settings. 

• The program files are 
installed. 

• Once all the files have 
been installed, the 
Complete screen is 
shown. Choose Finish to 
complete the 
installation. 

Installing the Adobe Acrobat Reader 
If you want to view the application documentation, you will need to have Adobe Acrobat 
installed. If you don’t have the software on your system, use the installer on the CD. 

# Note: If you’ve installed ‘over the top’ of a demo version, you’ll find that the 
documentation on the CD is likely to be a much larger file than the one you 
downloaded.  Although the manual is the same, the version on the CD has images 
saved at a higher resolution. You won’t notice much difference viewing the manual 
on screen, but you will certainly notice a difference if you print it. 

 

 

NeoGroup – Chapter 3 – Installation Page 6 



 

4 - Lic

 

NeoGroup –
4

ense Server 

Timestone Software’s Neo applications are protected from unauthorised use by a license 
server. The license server runs as a Windows NT service, and is installed as a component 
of the installer. It consists of several components: 

A hardlock or dongle that is connected to the Server PC’s Parallel port ! 

! 

! 

! 

# 

The License server, installed only to the server PC 
The License Manager which is installed to the Server, or can be used on a 
workstation connected to the network 
Several support files 

Understanding the License Server 
When a Neo application is licensed from Timestone Software, we issue your site with a 
hardlock or dongle. This hardlock contains a unique Key code that is specific to your 
installation. Without the hardlock, it is not possible to use the Neo application. 

It is possible to purchase single or multi-user licenses for Neo applications. When the 
license is issued, it is ‘added’ to the license server. You will then be able to use the number 
of applications you have licenses for. 

When a Neo application is started, it asks the License Server if there is a license available 
to use. If there is, the application will launch and ‘use’ a license. 

If there are no licenses available for that application, an error message will be given and 
the program will quit. You will not be able to launch the application until a license 
becomes available, either by adding more licenses, or by one of the users quits their 
running Neo application. 

Installing the License Server 
When installing the Neo application, choose the License Server component. The License 
Server service will be installed. 

It is not necessary to install the License Server on any machine other than the one 
that will host the hardlock. 
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You will be required to re-start the PC. Do so. 

Once the PC has been re-started, you will notice several things: 

A new control panel License Server has been added to the Windows 
Control Panel 

! 

! 

! 

! 

! 

! 

! 

A new service, Timestone License Server has been added to the Services 
list 
A new program, License Manager has been added to the Start > Timestone 
Software menu. 

Connect the hardlock to the License Server’s parallel port. 

Configuring and testing the license server 
The hardlock can be connected to any machine in the local area network. This machine 
doesn’t have to have a Neo application installed to act as a hardlock server. 

Hardlock and License Server installation 
First, make sure the hardlock is plugged into the hardlock server’s parallel port. Run the 
Neo application installer, and make sure that the License Server and Support Files 
components are chosen. It is not necessary to choose the Neo application component if 
this machine will not run the app. Allow the installer to re-start the PC as required. 

License Server configuration 
Open the Windows Control Panel. Locate the License Server icon, and double-click it. The 
License Server control panel opens. 

Enter the computer name for the hardlock server, and press Test. The License Server will 
then check to confirm the presence of the hardlock on the PC. If the hardlock is correctly 
detected, the control panel will report OK. If an error is displayed, confirm the following: 

Check you have entered the computer’s name correctly 
The hardlock is connected to the PC’s Parallel port 
The parallel port is functioning correctly 
Both the License Server and Support Files components have been 
installed 

If an error is still given, contact Timestone Software  or your distributor for support. 
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Enabling your licenses 
When you purchase the Neo applications you will purchase a number of user licenses. 
Timestone Software will supply a number of enable codes that will add licenses to the 
license server. These files are supplied either as an e-mail to your system administrator, or 
on a CD-Rom. The enable codes are shipped to you separate from the hardlock for 
security reasons. 

Adding the licenses to the license server 
Ensure that the hardlock and server software has been installed and successfully 
configured. 

From the Start menu, choose, Timestone Software > License Manager. The License 
Manager will open. 

Pay particular attention to any errors displayed in the Last Error section. Before any 
configuration has been carried out, it may display Missing/empty license code table file. 
This error will disappear once valid licenses have been installed. If the error reads 
Hardlock is invalid or missing, review the installation of the hardlock and License Server. 

If you need to open the License Server setup control panel, click the Setup button at the 
bottom of the License Manager. The License Server setup control panel will open. 

  

Choose the Codes tab. If licenses have not yet been added, this list will be empty. Any 
previously entered license codes will be displayed in this list. 

To add new licenses, click the Add file… button. A File Open dialog is displayed. Locate 
the license code files that have been supplied to you, and choose it in the list, then Open. 
After a brief pause, the new license appears in the list of added licenses and are available 
for use. 
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Each license in the list will note: 

The name of the licenses application ! 

! 

! 

The version number licenses 
The number of licensed users 

If you have more licenses to add, do so until you are finished. 

 

Configuring workstations to run 
Once the license server is installed and licenses added, each of the workstations of the 
LAN need to be configured. When the Neo application was installed, the License Server 
setup control panel was also installed. On each workstation that will use a Neo application 
license, open the Windows Control Panel, and start the License Server setup control panel. 

Enter the computer name of the PC that is hosting the hardlock, and press Test. If the 
computer could be found over the network, and its License Server was running correctly, 
OK will be  displayed in the Last Error area. If an error is displayed, ensure that: 

The license server PC is switched on, and the License Server is 
configured and running 

! 

! 

! 

It is connected to the network 
The workstation you are configuring can browse the network, and ‘see’ 
the License server PC 
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Close the control panel. The Neo application will now be able to launch, as long as a valid 
license is found on the License Server. 

Backing up your license server configuration 
If you want to back up your license server configuration, there is a single file to archive. 
This file is found in the License Server sub-directory of the main installation directory. 
Usually, this will mean a directory path of: 

 C:\Program Files\Timestone Software\License Server\ 

Back up the file: 

TsLServer.lct ! 
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NeoGroup is a highly automated creation tool for labs wanting to create traditional group 
images digitally. It offers tight integration with other Neo applications, sharing name and 
other data with these. There are many different ways NeoGroup can be used to create the 
group jobs, each method offering additional automation and labour saving. 

When creating a group image, name data is either imported or manually entered, the 
groups created, then the row lists are constructed. When production is ready to be run, the 
group is chosen, then a template selected. The template contains all the graphic elements 
required to create the final group, as well as special replaceable ‘@’ codes. This means 
that you can design a series of templates at the beginning of your season, include special 
text codes in the name board, as well as tagged graphic objects that represent the school 
logo, or perhaps the principal’s photograph. 

When the template is selected, the necessary data – such as the school name, class teacher, 
the school logo graphic and other variable objects is placed into the design. The result is a 
finished and attractive traditional group image, created with a minimum of effort. 

NeoGroup’s main features 

Image Handling 
Images imported to NeoGroup can be cropped, zoomed, and correct for colour, density 
and contrast. The aspect ratios involved in your production is previewed on-screen by 
super-imposing lines indicating the aspects. Images can be corrected quickly using either 
the mouse or keyboard. 

Name Data and Group structure 
Names can be either imported via a text file, or manually entered. Upon entry or import, 
the names are gathered into the relevant group lists for later use constructing the row lists. 
The data and images are gathered together as ‘Folders’ and ‘Groups’. Folders can contain 
more folders, allowing a natural data structure be created (The ‘Year 3’ folder is a sub 
folder of the ‘Junior School’ folder), as well as the groups themselves. 

Folders have special properties such as the ‘School Name’, or ‘Principal Name’ that 
allows the templates to gather the required data together for a particular group 
automatically. 
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Template based design 
NeoGroup uses a template to create the designs used for production. The templates can 
contain both fixed and variable objects, which are placed into layers in a template. Layers 
can be positioned in front or behind one another. 
Layers can contain bitmap or Vector (WMF) graphics, 
as well as text objects. 

Templates also support 1 bit image transparency, 
allowing images be placed ‘into’ another image. 

Variable objects 
NeoGroup templates allow special variable objects be placed into a design. These variable 
objects can be either text or graphic types, and allow a single template be designed and 
used for many different schools. For example, you might place an object into a design that 
represents the school logo. The logo bitmap is imported and identified as ‘Logo’ for this 
particular job. Once printed, NeoGroup fetches all the necessary variable objects, and 
places them automatically. 

Name entry 
Row lists can be constructed using pre-entered or imported name data for quick entry, or 
manually typed. If the name data is available, entry is done by typing a few characters of 
either the first or last name – or even an ID number. The names that match the characters 
entered are displayed for quick entry in the row list. 

If names have not been entered previously, the row lists can be constructed manually by 
entering the names. 

Job creation 
Jobs are finally created by choosing the group, then applying a template from those 
available. Groups can be created singly or as a group. 

Using NeoGroup’s interface 
Once NeoGroup has been installed, choose NeoGroup from the Start menu > Program Files 
> Timestone Software. NeoGroup will start. If you are asked for an unlock code, or told 
that the software protection device is not present, please review Chapter 3, Installing 
NeoGroup. 

There are 5 distinct modes of operation for NeoGroup. Depending on which mode you are 
in, the screen contents will appear quite different. Switch modes by choosing Mode > then 
the desired mode. The 5 modes are: 

Details mode – import and edit job name and other details ! 

! 

! 

! 

! 

Images mode – import crop and color correct the portrait images 
Names mode – add names to row lists 
Form Packs mode – form the finished pages 
Design mode – create the templates to be used for the pages 
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Image Mode 
Images are imported, cropped, corrected, then allocated to groups. 

 
Figure 1: Image Mode 

Details Mode 
Folders are created and manipulated, name data entered or imported. 

 
Figure 2: Details mode 
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Names Mode 
The row lists for each group are constructed. 

 
Figure 3: Names Mode 

Design Mode 
Design templates for use with your group images. 

 
Figure 4: Design Mode 

 

NeoGroup – Chapter 5 – Understanding NeoGroup Page 15 



 

Form Pages mode 
Where the jobs are finally created, ready to be printed. 

 
Figure 5: Form Page mode 

Common interface elements 
Regardless of the mode currently selected, there are several common elements you will 
see when using NeoGroup. 

Using toolbars 
Each of the NeoGroup toolbars features tooltips, and docking. 

Tooltips 
You can get a brief description of a toolbar button by pointing the 
mouse at a button for a second. A tooltip will appear, giving a brief 
description of the button. 

Resizing pane windows 
The three main pane windows can be resized freely. You can open a pane so it takes up the 
whole program space, or close it completely to allow space for other operations. 

Passing the mouse over the edge of the three panes will change the cursor to 
the pane move cursor. 

Click and drag the mouse – the pane will resize as you drag. 
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Figure 6: Resizing a pane 

# Each of the panes has a minimum size. If you drag the pane past its minimum size, 
it will completely close, and the other windows will expand to take its place. 

Shortcut keys 
There are many shortcut keys that allow quick selection of program options. These 
shortcuts are either indicated within a menu selection, or within the palette being used. 

For example, if you wish to adjust the image contrast, press and hold the Control key, then 
the C key. The value in the Contrast adjustment is hilighted ready for use. 

 

Palette shortcut indicated 
within the palette 
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nfiguring NeoGroup 

Setting the Program defaults 
There are a number of program defaults that need to be set to ensure NeoGroup is most 
useful to you. Things such as the location of various files and default fields need to be set 
for your lab. 

Open the Options dialog by choosing File, Options. 

 

Figure 7: Options dialog 

Measurement units 
From the Options panel, choose the General tab. Select your preferred measurement units, 
then choose OK. 

View size 
When displaying a pack preview, the display is relative to the size set here. For example, 
if a pack is 8 x 8", and the View size is set to a width and height of 20", the pack will 
appear quite small when previewed. Conversely, if a pack is 8 x 16", and the View size is 
set to 10 x 10", the pack will be clipped in the preview window. 
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Figure 8: The same group with the View setting set to 20x20 (right), and 12x12 (left) 

Image Editor 
NeoGroup allows editing of images via an external image editor (such as Adobe 
Photoshop).  In the dialog shown above, specify the image editor to use by either entering 
the path (including the program EXE) in the EXE filename field, or clicking the Browse 
button, locating and choosing the Image editor’s EXE file, and click Open.  The Image 
Editor is chosen. 

# Tip: Most program files are located in the Program Files folder. For example, the 
default location for Adobe Photoshop is C:\Program Files\Adobe\Photoshop\ 

Aspect ratios 
Aspect ratios in NeoGroup are particularly important. Due to the nature of Traditional 
Group photography, a single job can involve a number of different print sizes, even in a 
single roll of film. 

This means that you will probably use several different print sizes when printing your 
Traditional Groups conventionally. When using NeoGroup to create your work, you need 
to allow for this possibility as well. Often, this means that you will have several different 
versions of the same template, each one containing a different print size. 

The aspect ratios you use within NeoGroup than should reflect exactly the print sizes 
involved in your group prints. For example, you might use the following print sizes to 
cover all possible prints in your production: 

6x9" ! 

! 

! 

6x8.5" 
6x8 

You would then define these aspects within NeoGroup. 
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Determining the ideal crop 
Once defined, the aspect ratios are displayed super-imposed over the top of the group 
image. 

 

6:9 Aspect 

4:5 Aspect 

6:10 Aspect 

Figure 9: Cropping image showing 3 different aspect ratios 

As discussed later, you can jog an image by zooming the image, or moving it around. 
Using these controls, you can position and size the image so that it is cropped optimally 
for all the different aspect ratios. 

Defining Aspect Ratios 
Aspect ratios can be stored as a program default, or added to an image collection. New 
files will automatically contain the default aspect ratios which can then be added to. Any 
aspect ratios that you add to an individual file (via Edit > Aspect ratios…) are available 
only to that file. 

Program default Aspect Ratios 
From the File menu, choose Options. The Options dialog is displayed. Choose the Default 
tab. 

 
Figure 10: The Options Default tab 
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Choose Aspect ratios > Edit. The Aspect ratio editor is displayed. Any Aspect ratios 
defined here are available each time a new NeoGroup file is created. 

Defining Aspect Ratios 
Choose Edit > Aspect Ratios… the Aspect Ratio definition dialog is displayed. 

 

Preview guide on/off 

Aspect preview colour 

Aspect ratio height 

Aspect ratio width 

Aspect ratio name 

Figure 11: The Aspect Ratio dialog 

You will notice that the first time you open this dialog, there may be some aspect ratios 
already defined. These are the program default aspect ratios discussed in the previous 
point. 

Create a new Aspect Ratio 
 

Choose New from the Aspect Ratio dialog. A new Aspect 
Ratio is added to the list. 

! 

! 

! 

! 

! 

# 

Click inside the Description field, and type the description 
of the Aspect you are defining. 

Click inside the Width field and enter the width, then Height to enter the 
height amount. 
Click the color swatch. The color palette appears. Choose the color you 
wish the aspect ratio line to appear in the image preview. 
Click the On checkbox to display the aspect ratio in the cropping image 
preview. If this is checked, a line indicating this aspect ratio will appear 
in the image cropping window. If this is not checked, the aspect ratio will 
not appear. 

You can only use whole numbers to define a Width or Height. If your print size is 
6x8.5, multiply both values by 2, and enter 12 and 17 as the values. 

Import existing Aspect Ratios 
Aspect Ratios can be imported from existing NeoGroup files. Choose Import from File 
from the Default options tab. A Open File dialog appears. Locate the file that contains the 
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Aspect Ratios, choose it and click Open. The Aspect Ratios are imported as a program 
default. 

Change the list order 
The order Aspect Ratios is listed can be changed using the 
ordering arrows. 

Displaying an Aspect Ratio 
Once the default Aspect Ratios have been defined, any files created will 
contain these settings. To display the aspect ratio indicators, choose ‘Crop 
Image’ mode by choosing Images > Select crop & scale image tool, or 
clicking the ‘Crop Image Tool’ button on the toolbar. 

Active aspect ratios are now overlayed on the images. 

 
Figure 12: Image showing Aspect Ratio indicators 

Using the Aspect Ratio indicators 
The aspect ratio indicators show the edge of the various print sizes, allowing the best crop 
for the various aspect ratios being prepared to be decided. For information on zoom and 
crop operations, see Chapter 9, Images mode. 

Defining default Fields 
There are various information fields that are used in NeoGroup. Certain fields are best set 
as program defaults. Each time a new file is created, it will inherit the default values. You 
should review the later chapters in the manual regarding these fields before changing the 
settings here. 

Once you’re familiar with the usage of these fields, you can set the program defaults. 

Adding default fields 
Choose File > Options then choose the Default tab. 
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Click the Details Fields > Edit button. The default Data Fields dialog is displayed. Note 
there are three tabs. Each of these tabs allows global, major item and individual data fields 
to be set.  

The Subject Fields tab 
The Subjects Field tab contains fields that pertain to each individual appearing as a name 
in a row list. Please see Chapter 8, Details Mode for more information. 

 
Figure 13: The Subject Fields tab 

Adding a new field 
Click Add. A new line appears. Click the cursor in the Name entry area, and type the field 
name. 

# Fields are case sensitive. If you define a field ‘Name’, but place and @ code 
‘@name’ in a template, the text will not be correctly substituted. 
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Assigning a special attribute 
Fields can be assigned a special attribute that identify it for special use within the 
program. Attributes such as first, last or whole name identify a particular field. To assign a 
field attribute, choose the field, then cluck the Special drop-down for that field. A list of 
available attributes is displayed. 

 
Figure 14: Assigning a Field Attribute 

There are several special fields that are built-in to NeoGroup that are always identified as 
a special field. For the Subject Fields, these special fields are: 

 
Field Name Identified as… 

FirstName Identified as a subject’s first name 

LastName Identified as a subject’s last name 

WholeName Identified as the subject’s whole name 

 

The Folder Fields tab 
You can define default folder fields in this tab. 

 
Figure 15: The Folder Fields tab 
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The File Fields tab 
You can define default folder fields in this tab. 

 
Figure 16: The File Fields tab 

Once you have set the desired fields, choose OK. 

Monitor calibration 
NeoGroup allows your monitor to be standardised using the Monitor Calibration Wizard. To 
enable and run the wizard, choose the LUTs tab and ensure Enable monitor LUT is checked. 
If this option is enabled, the monitor calibration wizard must be run. See Chapter 13 for 
more information regarding calibration. 

Defining the High Resolution image and Design File locations 
Images can be imported with a reference to a high resolution image. In order to print with 
the high resolution data, NeoGroup must be told where to find these files. 

The way you set up NeoGroup to find the files can be done in several ways. It is 
recommended that you think how the image data will flow around your lab. For example, 
if you are a smaller lab, you might keep all the image data on the same machine that you 
create and print the jobs from. Alternately, you might be a larger lab who has several 
workstations sharing both jobs and the high-resolution images and templates. 

NeoGroup can also use the original location of the image files as the source. If the original 
files are moved to another location, then original link is invalid. NeoGroup will fall back 
to the path searching described next to try to locate the files. 

# If you ask NeoGroup to use the original file location to locate the image files, be 
sure that you still put the files in a predictable place. We strongly recommend you 
keep the high-resolution image files in an ‘Images’ directory, and each job’s files 
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are stored in a folder named with some identifier – perhaps the school name or 
booking reference. 

Setting the file locations 
To set the default image file paths, choose File > Options and choose the Paths tab, then the 
Image Files tab. Choose New, then enter the desired path. It is recommended that you use 
UNC (Universal Naming Convention) to specify the path. This avoids configuration errors 
when drive letters change un-expectedly. See a description of UNC naming later in this 
chapter. 

Once all the desired paths have been entered, choose OK. 

 

Specifying a path. 
There are several different ways a path can be ‘filled in’ by NeoGroup. They are: 

Path ‘Fill in’ type Usage 

Same directory as job file NeoGroup will look for the high resolution images in 
the same directory as the job file. Best for smaller labs. 

Sub-directory from job file NeoGroup looks for the high resolution images in the 
named sub-directory from that where the job file is in. 
Good for small or large labs 

Image root directory NeoGroup looks for the high resolution in a sub-
directory named the same as the job file. Best for large 
labs 

Absolute path NeoGroup looks for the files in the exact path as 
entered. This is not a recommended method. 

 
You should choose the method that best suits your lab’s workflow. It is possible to specify 
more than one path statement, although it is recommended that you choose and use one 
method only. 

Same directory as job file 
If the path statement is entered as: 

.\ 

 

NeoGroup – Chapter 6 – Configuring NeoGroup Page 26 



 

NeoGroup will search for the source images in the same directory as the .TNJ file. 

Sub-directory from job file 
Images can be stored in a sub-directory of the folder that contains the job file. For 
example, the job file is stored in a folder \Images\Job1, and the images belonging to that 
job in \Images\Job1\Source. If the path statement is entered as: 

 \Source 

NeoGroup will search for the source images in the \Images\Job1\Source subdirectory. 

Image Root directory 
Using an image root directory allows all images belonging to a job be stored under a single 
directory in its own folder. For example, you might set up a single image server named 
Ajax. This server has a drive shared as Data, and all images are stored in folders under the 
\Images folder. 

UNC naming allows this exact directory be specified from any workstation within the 
network, without using drive letters. This avoids configuration errors. The UNC name for 
a shared directory is \\Server\Share\Path. 

You may set your images up on this server as follows: 
 
 \Images\Job1 
 \Images\Job2 
 \Images\Job3 

Only the root folder is required. In this case, The root folder is \Images. So, the UNC 
name for the path would be: 
 \\Ajax\Data\Images\ 

Finally, we need to specify the final search directory to find the source images. Using the 
@+ code, NeoGroup adds the name of the .TNJ file to the search path as the final part of 
the path statement. In the above case, each of the .TNJ files would be named Job1, Job2 
and Job3. 

So, if the path is entered as: 
 \\Ajax\Data\Images\@+ 

and the file currently open is called Job2, NeoGroup will search for the original source 
images in: 

\\Ajax\Data\Images\Job2\ 

Absolute path 
Enter a path statement that points directly to the images. NeoGroup will look to this 
directory to find the images. Not a recommended method, as it is completely in-flexible. 

Adding a Design file location 
Templates can be stored in various places within your local area. The location of the 
templates must be defined before NeoGroup will ‘see’ them, ready for you to use. 
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Choose File > Options then choose the Paths > Design Files tab. Now, choose New. A new 
line appears in the list box. Enter the whole path for the location of the design files you 
want to use. You can use UNC (\\Zeus\Vault\…) or mapped drive letters as a valid path. 

After entering a new path, NeoGroup must be re-started before it will recognise the new 
entries and so see any templates in the new location. 
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NeoGroup can be configured for use in several ways. If your lab has access to name and 
other data to use to construct the row lists, the construction process is very quick and easy. 
You might like to configure it to use automated templates, or design a template for each 
school. Using NeoGroup all of NeoGroup’s automation features means that you will need 
to spend a little more time setting up a particular job, but overall the automation means 
that your production time and hassle levels will be lower. 

If you don’t want to use the automation features, or don’t have the row lists available as a 
data file, NeoGroup still allows you to create your Traditional Group jobs quickly and 
effectively. 

Understanding a NeoGroup job 
A NeoGroup job can start in several different places, depending wether photography has 
been done, and the scanned images are available, or if you have the name data as a text 
file. However the job starts, you will need to set up the file to reflect the structure of the 
groups being photographed. 

A NeoGroup job consists of various folders that contain the group images, matching name 
data (if available) and other variable objects such as the school name, logo image etc. 

NeoGroup presents these folders and groups in a similar manner to Windows Explorer. In 
the example below, we are working on a school, ‘Provident School’. This school has two 
major campuses, ‘Junior School’ and ‘Senior School’. Years 1 to 7 belong to the Junior 
School, and share a common Head Teacher, who has no relationship to the ‘Senior 
School’. Years 8 to 12 belong to the ‘Senior School’, and they have their own Head 
Teacher. 

Both the Junior and Senior school share the same Principal, School Colours and Logo. 
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Figure 17: An Image attached to a group 

Once a group has been created, it can be dropped into a Year folder and associated with a 
particular folder. Now, that group inherits all the special attributes of that folder, and those 
upstream from it. For example, in the above image, we are viewing the ‘Year 1B’ group. 
Year 1B is a member of the ‘Year 1’ folder. Upstream from the Year 1 folder, we see the 
‘Junior School’ folder, then the ‘Provident School’ folder, and finally the ‘Groups’ folder. 

Any information dropped into the ‘Year 1’ folder is available for use for groups in that 
folder. Similarly, and information dropped into the ‘Junior School’ folder is also available 
to the Year 1 thru 7 groups. However, any information dropped into the ‘Junior School’ 
folder is not available for use by ‘Senior School’ groups. 

Using this folder structure, it is possible to define data, text or graphic objects that can be 
available for a specific group only, to a major gathering of groups like the ‘Junior School’ 
folder. Likewise, you can define global properties that belong to all groups being created 
by this file. 

How to structure a job 
Generally, you will structure your files in two ways, depending how automated you want 
your production to become. 
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Full automation 

If you want to use all the automation functionality NeoGroup offers, you will need to set 
up a folder structure that exactly mirrors the structure of the groups you are 
photographing. 

 
Figure 18: A tightly structured NeoGroup file 

Loose automation 
You will always need to use some automation features when using NeoGroup. For 
example, the group name printed in the final product is always taken from the group 
name. However, if you don’t need automatically placed objects, and don’t need complex 
board name information, you can place groups loose under the ‘Groups’ main folder. 

 
Figure 19: A loosely structured NeoGroup file 

However, the automation features add so many possibilities, you’ll want to use them. 

Using Templates 
NeoGroup jobs are formed by applying a template to a group. A template contains all the 
graphic objects, text and the various placed objects, and so determines how the final job 
looks. The various images and text objects are placed in the designer, and saved as a file. 
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When a group is ready to be printed, the template is applied to the group image, and any 
of the necessary objects are automatically gathered together and placed on the image. 

Variable objects can be placed into a template, allowing the automation functionality of 
NeoGroup. The sorts of variable objects that can be placed include: 

Variable object Description 

Text or graphic 
object – File 

Text or graphic information that is common to all the groups. For 
example, the school name, or school’s logo. 

Text or graphic 
object - Folder 

Text or graphic information that belongs to a sub-group of the whole 
job. For example, a year grouping (Year 7), or a school campus 
(Junior School). Folder graphic objects might include a Year’s mascot, 
or the photograph of the ‘Senior School’ head teacher. 

Text object – Group Text or graphic information belonging to a group. For example, the 
group name (Year 7A) or the name and photo of the group’s teacher. 

 
In the following example, you can see several placed objects, both text and graphics: 
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‘Year 7A’. A ‘Group’ placed text object 
‘Provident High School – 2000’ A 
‘File’ placed object 

Group Teacher’s name. 
A ‘Folder’ placed text 
object 

Principal’s photograph. A 
‘File’ placed graphic object 

Logo image. A ‘File’ 
placed graphic object 



 

The template that creates this image might appear like this: 

 

Benefits of using templates 
Using templates to form the Group images offers great speed and flexibility for your lab. 
Design your templates at the beginning of the season, create the row lists with the 
photography data, then apply a template. 

Importing Name data 
NeoGroup allows existing name data be imported and used to construct the lists. If you 
don’t have this data, it is possible to enter the names manually. However, the task is much 
easier and quicker if the name data is available from some other data source. Even if the 
data source is not completely up to date, you should attempt to use such a source. 

Data sources 
Most schools around the world have some name information available in digital format 
that you can use with NeoGroup. It is possible to import name data from a text file, either 
delimited or fixed length. 

Typically, the data file would contain the first and last name, group and perhaps an ID 
number. Importing the text file creates all the necessary folders and places the member 
names into those folders. 
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A portion of a typical file would look like: 
"Amy","Batchelor","Year 7" 
"William","Brownlee","Year 7" 
"Tom","Carr","Year 7" 
"Amy","Coad","Year 7" 
"James","Cristofaro","Year 7" 
"Catherine","Hodge","Year 7" 
"Mandy","Hooper","Year 7" 

 

After the names have been imported, the 
following folder structure is created in 
NeoGroup: 

The names are now available for selection 
when constructing the row lists. If you don’t 
have a data source for the row lists, it is 
possible to enter the names manually either in 
the Details mode, or in the Names mode. 

Constructing the Row Lists 
Once the groups have been photographed, and you have received the row lists, it is 
possible to begin constructing the rows. 

Constructing Row Lists from imported data 
If name data is available, constructing the row lists is a quick operation. After choosing 
Name mode, the group you wish to work on is selected. The group image is displayed, 
along with the name entry panels. 

 

Specify the rows 
The first task is to specify the number of rows involved in the group image, and the 
number of people in each row. In the above example, there are 4 rows, with 6 people in 
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the back, 8 in the second, 8 in the third and 5 in the front rows. As each row is named, the 
number of people in the row is entered, and the necessary number of row positions is 
created, ready to receive names. 

 

Adding names – automatic 
If the names are available from the database, click in the position where the name is to 
appear. Decide how to search for the name. In this case, we are using the last name as the 
search field. 

As the last name is typed, names matching the entered characters are displayed. The more 
characters you enter, the more accurate the names displayed are. When you see the name 
you need, choose it and press Enter. The name is added to the list, and you can go on to 
add the next name immediately. 

  
Figure 20: Adding names from the database. Choosing the name from a list, and the name added 

Adding names – manual 
Entering names manually starts in the same manner as the automatic method. Instead of 
choosing from the list of available names, the name is directly typed in. 
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Forming Pages 
With the name lists 
constructed, it is possible 
now to create the final 
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group image. This is done in Form Pages mode. Here a list of the available groups is 
displayed, along with the templates. Creating the group is a matter of choosing the group 
or groups, then the required template. All the necessary pieces are automatically 
assembled, and the image is ready to be printed. 

 

Figure 21: A group image completed and ready to print 

The NeoGroup workflow 
Having seen broadly the pieces involved when using NeoGroup, it is useful to understand 
how the workflow is structured. 

Pre-season 
Before you start the season, design the templates you will want to use during the year. If 
the templates are well thought-out, there should be no reason to change the templates over 
your whole season. However, it is possible that you will do some fine-tuning of the 
templates as you proceed through the season. Things such as customising the background 
colours to mirror a school’s colours, add another logo and such. 

Pre-production 
Get whatever name data you can from the school and import it. This will construct the 
folder structure, making image allocation easier. Enter any of the variable data such as the 
school and principal’s, place any variable graphics such as the school logo. 

Actual production 
After the images have been scanned, or the digital camera files are available, import them 
to a NeoGroup job file. Allocate the images to and name each group. Construct the row 
lists using the imported data or manual keyboard entry. 

Crop and correct the group images, then apply templates. The jobs are ready to be 
proofed. After proofing, enter any corrections required and print the jobs. 
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In Details mode, the basic structure of the name data is laid out, and various special pieces 
of information relevant to the job are entered. If you have name data to import, or want to 
manually enter the data as a database, the process is done in Details mode. 

After starting the program, create or open a NeoGroup file by choosing File > New or File > 
Open. Now, choose, Mode > Details or press F4 on the keyboard. 

The Details screen is divided into 3 major sections: 

Name details 
code data

Folders

Defining the fields 
The fields displayed in these panes are defined as a program default, or for each individual 
file. There are three different types of field groups: 

File fields ! 

! 

! 

Folder fields 
Subject Fields 

File fields 
File fields are objects that are common to all the 
groups involved in the current job. Things like the 
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school name, the Principal’s name, and the school logo are good examples of File fields. 

To add a default File field, choose File > Options, then choose the Default tab. Now, click 
the Details Fields > Edit button. The Data Fields dialog is shown. Choose the File Fields tab 
and choose Add. A new line is added to the list of fields. Enter the name of the new field 
you want to use, then choose OK. 

Folder fields 
Folder fields are objects that are allocated to a 
particular folder, or a parent folder of a sub folder. 
Useful fields include the campus name for a school 
campus, a group teacher’s name, or a year’s mascot. 

To add a default Folder field, choose File > Options, 
then choose the Default tab. Now, click the Details 
Fields > Edit button. The Data Fields dialog is shown. 
Choose the Folder Fields tab and choose Add. A new 
line is added to the list of fields. Enter the name of 
the new field you want to use, then choose OK. 

Subject Fields 
Subject fields are that details you want to define for each individual person in the group 
photographs. Details such as the first and last names, ID, date of birth etc. If you have data 
that includes information that you don’t need to use in a group job, it is still recommended 
that you import the data, as it may be useful for other ‘Neo’ jobs. In this case, you should 
define the ‘extra’ fields such as Date of Birth, ID, Sport etc. in addition to the NeoGroup 
essentials of First Name and Last Name. 

When defining subject fields, you can identify a field type by clicking the Special drop-
down and choosing from the types available. The current selection includes: 

Type Explanation 

Whole name The subject’s entire name – do 
discrimination of first, last etc. 

First name The first name 

Last name The last name 

Middle name The middle name 

Birthdate The date of birth 
 

To add a default Subject field, choose File > Options, 
then choose the Default tab. Now, click the Details 
Fields > Edit button. The Data Fields dialog is shown. 
Choose the Subject Fields tab and choose Add. A 
new line is added to the list of fields. Enter the name 
of the new field you want to use, then choose OK. 
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Creating a folder structure 
If you are importing name data, the folder structure will be created for you from this data. 
It is possible to add, move or delete folders once they have been created, and you might do 
this to better mirror the structure of the school you’re working on. For example, you might 
want to move all the junior school classes into a ‘Junior School’ folder. 

If you don’t have data to import, you can create folders and enter data manually. 

Creating new folders 
When creating folders, you should first consider the school you are working on. If there 
are several campuses involved, you might want to add these campuses to your folder 
structure, and nest the classes under the campus folder. This becomes especially important 
if you are attaching a specific logo or using the campus name in your templates. 

To create a new folder, click the parent folder, and choose Edit > Create new folder. A new 
folder is created, ready to be named. Type the folder name and press Enter. 

Moving, deleting or renaming folders 
Folders can be moved, renamed or deleted. To move a folder, click and drag it to the place 
you wish to move. To re-name a folder, click the folder and choose Edit > Rename. Type 
the new name. To delete a folder, choose the folder you want to delete then choose Edit > 
Delete. You are asked to confirm the deletion. If you choose Yes, the folder is deleted. 

# If you delete a folder that contains names, the names are not deleted, but added to 
the Unallocated list. Any folder details that have been attached to the deleted folder 
are lost. 

Importing name data 
If you have name data to import, the required folders will be automatically created by the 
import process. The file to be imported should be a text file, wither delimited or fixed 
length. Ideally, each record should contain: 

First Name ! 

! 

! 

! 

Last Name 
Group 
ID (optionally) 

A typical text file might contain records similar to this: 
"Amy","Batchelor","Year 7" 
"William","Brownlee","Year 7" 
"Tom","Carr","Year 7" 
"Amy","Coad","Year 7" 
"James","Cristofaro","Year 7" 
"Catherine","Hodge","Year 7" 
"Mandy","Hooper","Year 7" 
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Prepare the import process 
Create a new file, or open the file you wish 
to import the data to. Choose Details mode 
by choosing Mode > Details or pressing F4 on 
your keyboard. Choose Subjects > Import 
text file… The Text file to import details 
dialog is displayed. Locate and choose the 
text file that contains the data. 

The contents of the file being imported 
needs to be specified.  Choose Setup from 
the Text file to import details dialog – the 
Setup subject details text file import dialog is shown. 

Specify the import type 
Choose wether the file being imported is a Fixed or 
Delimited file. If you are importing a delimited file, 
specify the delimiter – either choose by tab or by and enter 
the delimiter character. 

Map the fields 
Specify which field matches your data. You might have a file that looks similar to: 

"Amy","Batchelor","Year 7",”15568”,”260172” 
 

The fields in this record are: 

Record Field Field # 

Amy FirstName 1 

Batchelor LastName 2 

Year 7 Folder 3 

15568 ID 4 

260172 Date of Birth 5 

 

Enter the relevant field number for each available field. 

Updating existing data 
If you have already imported some details, it is possible 
to update the imported data in various ways. In order to 
update existing information, you need to specify a 
unique field that NeoGroup will use to identify the 
record to update. You would want to use an absolutely 
unique field such as an ID number to match on. 

Choose the unique field by choosing from the Unique field drop-down. 

Now, choose how the data is to be updated from the list available. When NeoGroup finds 
a record that it can update, it can: 
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Choice Description 

Leave existing details The record will not be updated with the new data in any way 

Always replace 
existing details 

A matching record will be replaced completely with the new 
data. If the new data contains a blank field for a record, the old 
record’s field will be replaced with the new blank field. 

Replace existing 
details only if blank 

A matching record will be updated with the new data only if it is 
empty. 

Update existing 
details 

A matching record will be updated with the new data. If the 
new data contains a blank field, the old record’s field will retain 
its current information. 

 

Import the name data 
Once you're happy with the settings, choose OK to dismiss the Setup subject details text 
file import dialog, then select the text file and choose Open. The data is imported. 

Editing the details and folders 
Often you will find that the data you import will not completely suit your needs for 
NeoGroup. For example, you might want to sort the folders created by the import into 
senior and junior school groups. 

After the import has been completed, you can add, edit or move the folders to suit your 
needs. You can add, rename or move folders by clicking, dragging and dropping them as 
you normally do in Windows Explorer. 

  
Figure 22: Folders after importing data, then after editing the folder structure 
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Allocating File and Folder details 
As previously discussed, it is possible to enter special details to the whole file, or to 
individual folders in a file. This data is used when the template is ‘filled in’ when finishing 
jobs. The details are entered by choosing the file or folder, then typing the data into the 
field. 

Adding File details 
File details are a global property. Things such as the school’s name, the year of 
photography, or perhaps the school’s logo are File details. To allocate File details, choose 
All in the folder tree listing. Note that the fields available in the Field / Value section 
change to match those defined for this file. 

Choose the field you wish to name, and enter the data. 

 

Adding Folder details 
Folder details can apply at several levels. For example, you might have a folder ‘Senior 
School’ that contains all the senior groups. You might want to use ‘Senior School’ as a part 
of the final group image (the board might read ‘Provident High School – Senior School – 
Year 10A’). Rather than create a template that contains ‘Senior School’ written as plain 
text, you can include a special code that instructs NeoGroup to look for the text it should 
insert. So, your template could be used for the Junior School, as well as the Senior School 
without changing it. 

Similarly, a year group could include the teacher’s name for inclusion in the final image. 

NeoGroup uses a ‘searching’ mechanism that allows you to specify information that 
belongs to a number of groups, as well as information for an individual group. In the 
below example, Year 10A is a member of the Year 10 folder, which is a member of the 
Senior School folder. Clicking on the ‘Senior School’ folder reveals that the fields, 
‘Teacher’ and ‘SchoolType’ are available. In the case of the ‘Senior School’ folder, click in 
‘SchoolType’ and enter the name that will appear in the template. 

Now, for an individual group, we want the teacher’s name to appear. Choose the 
individual year group, and enter the teacher’s name. 

When the job is run, NeoGroup will place ‘Senior School’ into the template for all the 
Senior School groups, and the teacher’s name for each individual group. 

To enter the information, click the folder, and then the Value for the field you need. Type 
the data. 
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Multi-line Value entries 
Field values can contain a carriage return, allowing a single value to be spread over 
several lines. This is done by entering a special code in the Value field. 

To enter a carriage return, type the first line, then either: 

Press <Control> <Enter> ! 

! Press the Numeric Keypad <Enter> key 

The carriage return symbol is placed into the text. 

 

 Inserted Carriage return

 

Tagged graphic objects 
NeoGroup templates can include referenced images that are placed into the final design. 
These referenced  images are created in Design mode for either the entire file, or 
individual folders. This is especially useful if your template designs include a school logo 
– you can include a tagged object in the template that references the logo image which 
you place here. 
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Creating a Tagged object field 
To include tagged graphics into a template, you must first create a special ‘Graphic’ field 
to contain the images. It is best to set these fields as a program default. Choose File > 
Options, then choose the Default tab, and click Data fields > Edit. The Data Fields dialog is 
displayed. 

Choose the tab you wish to use – either Folder or File. See the earlier discussion about the 
difference between these fields. 

We will use the example of a School’s logo for this example. 

Creating a File graphic field 
Choose the File tab, then click Add. A new line is inserted to the list of fields. Type the 
name of the graphic field. In this example, type SchoolLogo. Now, click the Type drop-
down and choose Graphic from the list. 

Choose OK. The graphic field is now available. 

 

Adding a graphic to a graphic field 
Once the graphic field has been set as a program default, choose File > New to create a new 
file with this field, or add it to the file by entering Details mode, then choosing Edit > 
Fields… and adding the graphic as before. 

You will see the new field in the list of available fields when All is chosen. 

 

Double-click inside the Value for SchoolLogo. The Open Graphic dialog is displayed. 
Navigate through and find the graphic file you wish to import. 

Set the import options 
As when you normally import images to use within NeoGroup, you must import the 
tagged graphic objects in order to use them. There are several options available to you 
when importing the objects that allow NeoGroup to find the high-resolution images when 
they need to be printed. For information about this, please consult the following chapter, 
Image mode. 

 

NeoGroup – Chapter 8 – Details Mode Page 44 



 

Choose the import option you wish to use, then choose Open. The file is read, and the 
Graphic value dialog is displayed. 

  

# If you wish to use a transparent background for your logo, you will be able to 
specify a colour that will be transparent. When designing your logo graphics, you 
must be very careful how the image is prepared to avoid halos or other un-wanted 
artefacts within the image. In particular, you must not use images that have been 
JPEG compressed. JPEG compression will introduce artefacts at the edges of your 
logo. We recommend you use PNG compression instead. 

Choosing the transparent area 
Once the graphic is displayed, you can choose the area to be transparent. In this example, 
we want the background white area to appear as transparent. Using the mouse pointer, 
click the white area. The transparency is indicated by the hashed area. If you have 
previously set a colour to be transparent, but then don’t want to use a transparency mask, 
click No mask. 

# Make sure you design your logo graphics carefully. Any area that is the same colour 
as you click will appear as transparent in your design. In this example, if the colour 
of the banner ribbon was also white, it would appear transparent in the final job. 
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Once you are happy with the settings, choose OK. The dialog is dismissed, and the graphic 
object now is named in the field value in Details mode tree view. 

Allocate graphic objects in the same manner for Folders. The graphic object is now 
available for use in a NeoGroup template. 
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Once imported, Group images can be zoomed, cropped, and adjusted for colour, density or 
image contrast. Images are also ‘dropped’ into groups for use in a group image. These 
operations are carried out in Image mode. 

Entering Image mode 
After starting the program, create or open a NeoGroup file by choosing File > New or File > 
Images that you want to use with NeoGroup need to be imported to a job file. This process 
creates a smaller version of the high-resolution image that is used when creating the 
NeoGroup jobs. 

There are several ways images can be used by NeoGroup. Either create a link to loose 
images on a hard disk, or import the images to a single image file. Once the images have 
been imported to NeoGroup, they can be cropped, jogged, the colour or density corrected, 
and then added to a package queue. 

Open. Now, choose, Mode > Image or press F5 on the keyboard.  The Image screen is 
divided into 3 major areas: 

 

Image Preview 

Folders tree 
 

 Corrections toolbar 
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Importing images 
Images you wish to use for group images need to be imported to the NeoGroup file you’re 
working on. There are a number of operations that can be applied to images as they are 
imported. 

Adjusting the Image Preview quality 
When an image is imported to the NeoGroup file, the high-resolution image is sub-
sampled for display purposes. If you want a higher quality preview image, you can adjust 
the size of the preview image created. 

With a file open, choose File > Properties. Choose the Bitmap sizes tab, and enter the 
desired preview size in the Stored size of bitmap used for previewing entry box. 

# Adjusting this amount will not change preview images already created. You must 
re-import the images to see the changed setting. 

Import the images 
Once the various file options have been set, you can 
import images to the job file. With the job file open, 
choose Images > Images from disk. The Images From 
Disk dialog is shown. 

 

Configuring the import 
There are a number of options that are available to you 
when importing images. 

Choose the files to be imported ! 

! 

! 

! 

! 

Specific a range of files to import 
Rotate and flip images as they are imported 
Apply a LUT correction 
Apply image sharpening 

Set the import options 
From the Images from disk… dialog, click the Setup button. The Setup dialog opens. Click 
Setup. The Images From Disk Setup dialog opens. The dialog is divided into 4 main areas 
that control the various options available to you. 
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Set the import type 
Decide wether you want to import the preview only, or the whole image data. If you want 
to import the preview only, make sure the Import preview only checkbox is checked. Now, 
choose from the two options to specify how NeoGroup will locate the original image files 
when printing or exporting images. 

Remember the actual path of each image – NeoGroup remembers the 
original location of the high resolution images 

! 

! Discard the path… – NeoGroup uses the image search path specified as a 
program option to locate the high resolution images 

For more information regarding these options, refer earlier in this chapter. 

 

Set the image rotation / flip 
If the images you are importing need to be rotated or flipped, choose the rotation here. 

# Note: If you import images by preview only, choosing an option here will cause 
longer print times as the image will be rotated or flipped at print time. To ensure the 
shortest possible print times, ensure the images are in the correct orientation before 
they are imported. 
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Set the image LUT 
Images can be corrected using the built-in LUT editor. For information on using the LUT 
editor, see later in this chapter. Choose the LUT you want to use from those defined in the 
drop-down list. For information in making a LUT, please see Chapter 10, Calibration. 

 

Set the image sharpening 
Images can be sharpened as they are imported. The algorithm used is an un-sharp mask 
algorithm, allowing good quality sharpening. 

 

The setting range is: 

Kernel: 3, 5 or 7 
Strength: 10 - 600 

Generally, the larger the kernel size, the stronger the sharpening effect. Likewise, the 
higher the strength, the stronger the sharpness. The higher the kernel value, the longer it 
will take to apply the sharpening effect. 

There is no ‘correct’ sharpness value – the values you will use depend on how sharp the 
original images are. You should try importing a sample image with different sharpening 
settings to find the correct value for you. Be aware that increasing the sharpness of an 
image too much can result in harsh and unpleasant images. 

# Whenever you apply a correction such as image sharpening, you will increase the 
time taken to print an image. If your scanner or scanning software supports image 
sharpening, you should try to use these controls rather than applying a sharpening 
amount within NeoGroup. 

Once all the settings have been made, choose OK. The dialog is dismissed. 

Choose the files to import 
There are two ways to choose the images to import to a NeoGroup job file: 

Import images using a mask ! 

! Import selected images 
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Import images using a mask 
If you have a range of images to import, NeoGroup can choose the images to import, as 
well as identifying any important information embedded in the filename using the Import 
From Disk Masked dialog. 

From the main Images from Disk dialog, click Using mask… The Import From Disk Masked 
dialog opens. 

Choose the image directory 
Enter the path to the image files you want to import. You can click the Browse button to 
open a Browse dialog. 

Specify the file range to import  
NeoGroup can use a mask to select the files to import, as well as identify important 
information embedded in a filename. 

For example, a set of files might be named: 

Image 1 Image001exp.tif 

Image 2 Image002exp.tif 

Image 3 Image003exp.tif 

… Imagexxxexp.tif 

 
These filenames consist of a prefix, the unique number, then a postfix: 

prefix: img ! 

! 

! 

! 

! 

! 

! 

! 

number: 001 – xxx, 3 digits long 
postfix: exp 
extension: tif 

The important information can be imported along with the image data by specifying the 
location of the data within the filename. In this case, you would enter: 

‘Image’ as the pre entry 
3 as the no-width entry 
‘exp’ as the post entry 
‘tif’ as the ext entry 

With these settings made, any files that don’t conform to this filename mask will be 
ignored. If the pre, no-width and post fields are left blank, any eligible bitmap files found 
in the specified directory will be imported. 

Specify a file range limit 
You can choose to import a range of images from the valid range. For example, if you 
want to import image 20 to 40 out of 100 valid image files, you would enter 20 and 40 in 
the Limit from image no… to image no boxes. Image files 20 through 40 will be imported. 
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Once you have made all the settings, choose OK. The Images From Disk Masked dialog is 
dismissed. Note that in the main Images From Disk dialog, you will now see a list of the 
files that will be imported according to the entries made. 

  

Import selected images 
If you want to import a number of selected image files, you can choose the files to import 
using the selected… dialog. Click Selected. The Import From Disk dialog opens. Choose 
the files you want to import. You can use the standard Windows modifier keys to select 
the various file ranges. These modifiers are: 

<Shift> click first then last file in a range – selects a block of files. ! 

! <CTRL> click each file you wish to import – selects the files to import 
individually 

Choose the range of files to and choose OK. 

 

Specify the image import order 
Open the Import Options panel by choosing Image > Import options panel… Note the status 
of the Incoming images section of the Import Options. If the file currently open is indexed, 
the options will be unavailable. If the file currently open is sequential, the options will be 
available. 
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Using linked job files 
Once images have been link-imported to the job file, the original hi-res images are not 
required until the jobs are printed or exported to the hard disk. It is not possible to edit 
images with an image editor directly from NeoGroup when using linked files. This means 
that the smaller .TNJ file can be sent anywhere without the source images for image 
colour correction, cropping and pack creation. 

Missing image files 
If the original image files are not available when printing or exporting the images, an error 
is shown. Either fix the problem and choose Retry to retry the job, or Abort to abort the 
current operation. Fix the problem and try again. 

 

Specify the image import order 
Open the Import Options panel by choosing Image > Import options panel… Note the status 
of the Incoming images section of the Import Options. If the file currently open is indexed, 
the options will be unavailable. If the file currently open is sequential, the options will be 
available. 

  
  

 
Bi
Th
pa

On
ho

Th

 

NeoGroup – Chapter 9 –
Unavailable Image options for an 
indexed file 
tmaps imported to a sequential file are num
e images are imported in order according t
nel dialog. 

ce images are imported to a sequential file
wever many images are in the file (1, 2, 3, 

ere are various import options that availab

Reverse order: Imports images in reve
001) 

! 

! To end: Appends all new images to th
order is selected, images are appended

 Images Mode 
Image options available for a
sequential file 
bered internally with a sequential number. 
o the parameters set in the Import options 

, they will have numbers allocated from 1 to 
4…) 

le: 

rse numeric order (999 first, to 

e end of existing images. If Reverse 
 before the first image if it exists. 

Page 54 



 

Insert: Inserts imported files from the currently selected image (only 
available if images have already been imported). 

! 

! 

# 

Replace: Imported files overwrite existing images from the one currently 
selected (only available if images have already been imported). 

If Insert is selected as the import option, images are inserted from the point of the 
image currently selected. If you select a new image during the import, the insertion 
position is retained. If you want to specify a new insertion point for imported 
images, pause the import by choosing Pause import, the new insertion point, then 
click Insert once again in the Import options panel. The new insertion point is set. 

Other import sources 
NeoGroup also allows images to be imported from several other image sources. The 
import panel can be hidden after starting the import by choosing Hide. Any eligible images 
will continue to be imported until importing is paused or the source unchecked. 

Setting up the import 
Choose Setup from the Images From Hot Source dialog. The setup dialog is displayed. 
Images can be rotated and flipped as with importing images from the specified source. 
These settings are discussed earlier in this manual. 

 

Specify a LUT 
NeoGroup allows image corrections to be applied as images are imported. For example, if 
you know that a particular source of images needs to be brightened, the correction can be 
applied as it is imported. 

Choose the LUT that you need from the Apply LUT drop-down. For information in making 
a LUT, please see Chapter 10, Calibration. 
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Importing from the Windows clipboard 
If your have an application or scanner that can place the images into the Windows 
clipboard, NeoGroup can import these images directly. 

Choose Image > Import from hot source… The Import from hot source dialog opens. Make 
sure Clipboard is checked, and Pause importing is unchecked. Any images that appear in 
the Windows clipboard will be inserted to the currently open file. The images are inserted 
according to the options set in the Options panel as previously discussed. 

Importing from Kinetic bitmap devices 
Some other imaging applications use this method as an image interchange. If your device 
is compatible, images will be inserted automatically according to the settings made in the 
Options panel. If you’re not sure if your device is compatible, check with Timestone 
Software. 

 
Figure 23: The Images from hot source panel. 

 
Figure 24: Import panel with indexed images 

Editing images while importing 
It is possible to edit (zoom, crop and colour correct) images whilst images are being 
imported. During the import operation, the editing operation is not as responsive as it 
would normally be, and we recommend that you use the keyboard to perform the edits. 

The image import can still be controlled, even though you may have hidden the main 
image import dialog by choosing the Hide button. Open the Import options panel by 
choosing Images > Import options panel…. This small panel can be positioned on the 
screen so the image import can paused or restarted. 
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Adding images 
Images can be added to a file, or can over-write existing images within a file. Images are 
added by using the Images > Import from Disk dialog. The options available vary according 
to wether a file is indexed or sequentially numbered 

Add new files to the end of an existing file 
Choose Images > Import options panel… The Images Options Panel opens. Choose To end 
as the Incoming images selection. Specify the files to be imported as previously discussed. 
Images will be appended to the end of the file. 

 

Insert or replace files within a file 

To add images somewhere in the middle of an existing file, first choose the image where 
the new images are to be inserted or replaced, then choose Images > Import options panel… 
The Images Options Panel is shown. Note that the options Insert and Replace are available. 

Images that are imported with Insert selected will be added from the selected image. 
Images imported with the Replace option selected will overwrite existing images from the 
selected image. 

 

Deleting images 
To delete images, you must first choose All in the tree view. After selecting All, choose the 
image you wish to delete, then press the Del key, or choose Edit > Delete. A confirmation of 
the deletion is requested, then the images are removed. Choose OK – the image is deleted. 
Any groups that used deleted images will not be removed 

  

Closing and compacting files 
Close a file by choosing File > Close, or by clicking the File Close button in the toolbar. 
The current file is closed. 

Images are stored in NeoGroup’s database type file. As images are deleted in the program, 
they are not physically removed from the file, although they are no longer available. One 
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result of this is that the file size will remain the same, even if all the images are deleted 
from the file. 

The deleted image space is ‘freed up’ by choosing File > 
Close & Compact. This process takes a little time to 
perform, and also requires some hard disk space (at 
least as much as the new file’s size). Once done, the file 
will only contain the essential image data, and be as 
small as possible. 

It is recommended that a file is compacted after many images have been deleted, or before 
being archived. 

Allocating images and creating groups 
Once images have been imported, they are allocated to the various groups and folders for 
use with the group images. This is done by dragging and dropping un-allocated images to 
the required group. 

How you identify images to be allocated will depend on your 
circumstance. In many cases, the group images will have a 
board in the photograph, aiding identification. You may also 
have a shoot order that will serve as a key to the group. By 
choosing Images > Show Tags, NeoGroup will display the 
original image filename that was imported, making this match process easier.  

NeoGroup ‘Groups’ 
A Group in NeoGroup is a very important object. As we have seen, Folders can be created 
by importing name data, or manually creating them. A folder 
needs to have a group created within it in order to produce a 
group job. You can think of the folder as the container that 
holds all the necessary components (the names, the group 
image…) that will finally form a group image. Groups can be created by either manually 
creating a group, or by dragging and dropping a group photograph onto a folder. 

The group’s name 
The name you give a group when it is created is most important. The name typed here is 
the name that will appear in the centre board in the final NeoGroup job. For example, if 
you name a group ‘Grade 7A’, this is what will appear in the centre board if called for. 

Manual creation of groups 
If the image file to be used in a group is not yet available (the film may be being used 
elsewhere), you can create a group manually, and fill out row lists. 

To create a group manually, choose the folder that will contain the 
group, then choose Edit > Create new group, or click the New Group 
icon in the toolbar. A new group is created. Type the group’s name, 
then press Enter. 
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Drag-drop creation of groups 
After images have been imported, they can be allocated to folders by drag and drop. Click 
Unallocated in the tree view to see all the images that have yet to be allocated to a folder 
or group. Choose the image you want to allocate to a particular folder or group, click it, 
and hold the mouse button down. Now, move the mouse to hilight the folder or group 
required and release the mouse button. The image is dropped into the folder or group 
selected. 

If you dropped the image onto a folder, a new group is created ready to be named. If you 
dropped the image onto an existing group (perhaps created manually as discussed before), 
the image is added to that group. 

If you have more than one image of a particular group (perhaps one with identifying name 
tags, the other the actual group photpgraph), drop all the images belonging to the single 
group onto the same group photograph. You can choose which image you wish to use 
later. 

Note that after the drag and drop operation, the selected image is moved from the 
Unallocated group at the top of the tree view to the group you created. Choosing 
Unallocated will show that the image is no longer available to be allocated. 

 
Figure 25: Click the image, drag and drop it onto a folder or existing group 

 
Figure 26: After the drag and drop, name the group 
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Allocating multiple images 
You may have several images that belong to a single group. Perhaps one image has each 
person holding up a name tag, with the other the actual group shot. You can allocate 
several images by dragging and dropping them into a folder or onto a group. 

Allocating multiple images to a folder 
To allocate several images to a single new group, select the images required, then drag and 
drop them to the folder. The images are allocated to a single new group. Type the group 
name and press Enter. 

Allocating multiple images to an existing group. 
To allocate several images to an existing group, first make sure you can see the target 
group in the tree view. Do this by clicking the + icon next to the containing folder. Now, 
select the images required, then drag and drop them to the folder. The images are added to 
the existing group. 

Setting the default image 
When several images are allocated to a group, you can set one image to be the default. 
The default image will always appear first when viewing of the images, and will always 
be printed. When editing the images, you would always choose the best image to be the 
default. 

Choose the group that has several images. Either double click the image you want to be 
the dafault, or choose Images > Make the selected image primary. The selected image is 
moved to the first position in the list view. 

Editing and displaying images 
After the group images have been imported, you can edit them for zoom, crop, colour 
density and contrast. You can also control how the images are displayed on-screen for 
convenient image editing. 

Changing the image display 
You can control the number of images displayed on-screen using the image pane controls. 
These are located at the bottom of the image preview pane. 

Image set controls 
Choose the number of images you wish to display using the controls 

Choosing Single Image changes the image display to a single image. ! 

! Choosing Multiple Images changes the image display to the image table. 
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Figure 27: Image preview in single and multi image modes 

Changing the number of images displayed 
Clicking the Number of images button pops up a sizeable grid. 
Moving the mouse increases or decreases the number of 
images displayed in the image table.  

Editing Images 
Once images have been imported to NeoGroup, they can be changed in various ways: 

Zoom ! 

! 

! 

! 

Jog (x-y movement) 
Color, density and contrast corrections 
Image editing via an external image editor 

There are many shortcuts available to achieve the various corrections, as are there many 
different ways to change the size and number of images being displayed. 

Selecting images 
It is fast and convenient to select and navigate through images in the image table. First, 
choose an image by clicking on it with the mouse. 

Action Keyboard 

Select the first image Press the Home key 

Select the last image Press the End key 

Show the next screen of images Press the Page Down key 

Show the next screen of images Press the Page Down key 

Move to the Left image Press the Left arrow key 

Move to the Right image Press the Right arrow key 

Move to the image above Press the Up arrow key 

Move to the image below Press the Down arrow key 
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Zoom and jogging images 
Images can be moved and re-sized to create the best cropping for various aspect ratio 
prints. When in cropping mode, NeoGroup displays any enabled aspect ratios. Images 
should be cropped so that each of the different aspect ratios will appear pleasingly 
cropped. 

There are many different ways to zoom and crop images. Zoom and crop values ultimately 
are displayed in the Image Corrections palette. If the Image Corrections palette isn’t 
currently open, choose View > Image Corrections. Choose the image crop editing mode by 
choosing Images > Select crop & scale image tool. 

Note that all images displayed in the image table now show the enabled aspect ratios. 

Cropping images 
Choose an image. The image can be cropped by: 

Action Keyboard Mouse Image Correction palette 

Move an 
image left 

Hold the Control key 
and press the $ key 

Click and drag the 
mouse 

Click inside the ‘X’ value box, 
or Press <Control><X>. 
Decrease the value or press 
the % key 

Move an 
image right 

Hold the Control key 
and press the & key 

Click and drag the 
mouse 

Click inside the ‘X’ value box, 
or Press <Control><X>. 
Increase the value or press the 
' key 

Move an 
image up 

Hold the Control key 
and press the ' key 

Click and drag the 
mouse 

Click inside the ‘Y’ value box, 
or Press <Control><Y>. 
Decrease the value or press 
the % key 

Move an 
image down 

Hold the Control key 
and press the % key 

Click and drag the 
mouse 

Click inside the ‘X’ value box, 
or Press <Control><Y>. 
Increase the value or press the 
' key 

Zooming images 
Choose an image. The image can be zoomed by: 

Action Keyboard Mouse Image Correction palette 

Make the 
image larger 

Hold the Control key 
and press the Page 
Down key 

Hold Control key 
and turn the scroll 
wheel or, hold the 
Shift key down and 
move the mouse 
up 

Click inside the ‘S’ value box, 
or Press <Control> <S>. 
Decrease the value or press 
the % key 

Make the 
image smaller 

Hold the Control key 
and press the Page 
Up key 

Hold Control key 
and turn the scroll 
wheel or, 

Hold Shift key 
down and move 
the mouse down 

Click inside the ‘S’ value box, 
or Press <Control> <S>. 
Increase the value or press 
the ' key 
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Moving images outside the image area 
It is possible to move the images outside the image area. This might cause white borders 
in the finished packages. If you move an image too far, you will see indicators. The 
indicators show where the image has been incorrectly moved. 

 

 

 

Out of image area indicators

Zooming and jogging in practice 
Adjusting the size and position of images for the various print sizes to be printed is a most 
important task. If many images are to be adjusted, it is important to perform the task as 
quickly and accurately as possible. 

In practice, some operators will prefer to use the keyboard to make these adjustments, 
whilst others will prefer to use the mouse and keyboard. 

Using the mouse and keyboard. 
Select the image to be corrected ! 

! 

! 

! 

! 

# 

Hold the Control key down and use the scroll wheel to zoom the image. 
Release the Control key, click and drag the mouse to adjust the image 
position. 
Click the next image and repeat the operation. 
When you need to see the next screen of images, turn the scroll wheel. 

Note that the control panels associated with scrolling mice often allow the scroll 
wheel to move a certain number of lines per ‘click’. You should set it to suit your 
needs. If the scroll wheel is set to ‘1 line’, the image table is moved 1 row per 
‘click’. If it is set to 3 lines, the image table is moved by 3 rows per ‘click’. 

Using the keyboard 
Select the first image by pressing the Home key. ! 
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Choose the image to be adjusted with the Arrow keys. ! 

! 

! 

! 

! 

Hold the Control key down and use the Arrow keys to move the image. 
Hold the Control key down and use the Page Up or Page Down keys to 
zoom the image. 
Use the Arrow keys to choose the next image to be edited. 
Use the Page Up or Page Down keys to see the next or previous page of 
images. 

Adjusting the image colour, density and contrast 
Image colour, density and contrast can be changed using the image density controls. The 
corrections can be applied across a group of images, or individually. 

If you find it cumbersome using the mouse in this situation, there are a number of shortcut 
keys available: 

Action Keyboard shortcut 

Increase brightness Type <Control><I> and press the ' key. The ‘I’ value increases 

Decrease brightness Type <Control><I> and press the % key. The ‘I’ value decreases 

Increase contrast Type <Control><C> and press the ' key. The ‘C’ value increases 

Decrease density Type <Control><C> and press the % key. The ‘C value decreases 

More red Type <Control><R> and press the ' key. The ‘R’ value increases 

More cyan Type <Control><R> and press the % key. The ‘R’ value decreases 

More green Type <Control><G> and press the ' key. The ‘G’ value increases 

More magenta Type <Control><G> and press the % key. The ‘G’ value decreases 

More blue Type <Control><B> and press the ' key. The ‘B’ value increases 

More yellow Type <Control><B> and press the % key. The ‘B’ value decreases 

Exporting images 
You can export images from NeoGroup and thus make them available to other 
applications or for other purposes – for example, you might need to supply the images to 
the printer who has been commissioned to publish a yearbook which features all the 
images in a particular job file. 

NeoGroup gives you control over the following parameters of the export: 

• If the subjects in your job file are arranged into folders, you can use these folder 
names to create directories for the export so that exported images are divided 
neatly into a directory structure.  Alternatively, you can use the existing folder 
names in the filenames which are created during the export process. 

• Subjects in a NeoGroup job file have fields associated with them (names, ID 
numbers etc) and you can use any existing field in the filenames which are created 
during the export process 
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• You can apply an LUT to the whole batch of images you are exporting. 

• You can apply sharpening to the whole batch of images you are exporting. 

• You can resample each image in the whole batch to different size 

• …and, of course, you can export in any of the most commonly-used file formats, 
JPG, BMP, PNG, TIF, TGA, PCX or PCT. 

To export images, make sure you’re in Image mode, then choose Images, Export. The 
Export images dialog box appears – all you can do here is specify a path and start the 
process.  Not much will happen, however, unless you first click the Setup button and 
specify how you want the images exported: 

 

Figure 28: Images Export Setup dialog 

Shown above are the default settings. 

# Note: If you change the file format from the default of .jpg, make sure you change 
the extension (in the Filename format area of the dialog) to match. This doesn’t 
happen automatically, and if you don’t change it you may end up with BMP files 
that all have .jpg extensions. 
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Names mode 

Construction of the name row lists is done in Name mode. After groups have been created, 
names can be allocated to a row. Groups don’t have to have images allocated to construct 
the rows, nor do you need to have imported name data. 

However, you must have created a group in Images mode in order to create the row lists. 

Creating the row lists is done by either manually entering each name in the row, or by 
selection from the names entered in the database. 

If you want to create group images without names, you don’t have to define any of the 
row lists. To create ‘no-names’ groups, check the next chapters, Printing and Creating 
Templates. 

The Names mode interface 
Enter Names mode by choosing Mode > Names. The names mode window is shown. The 
window is divided into 4 areas: 

 

Group image preview

Row list

Find names 
 

Row names
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Selecting the group 
The first step when creating the row lists is to choose the required group. 
Click the Select Group icon in the toolbar. The Select Group dialog is 
displayed. 

Click the group you wish to use and choose OK. 

 

Creating the rows 
After selecting the group, the first step in creating the row list is to define the number of 
rows. Then, the number of people in each row is defined, then the names inserted to the 
correct position. 

Define a row 
Click the cursor inside the first entry in the Row pane. Type the name for the row. Now, 
count the number of people in the row from the preview image and insert this number in 
the Count box. The required number of positions is created ready to insert names. 
Continue entering rows until they are completed. 

# You don’t have to enter the number of positions in a row. As names are entered to a 
roe list, the count will automatically increment. However, it serves as a good check 
when entering names that the correct number of names has been entered. 
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Adding absentee or other special rows 
If you  want to create an Absent or other special list, create and name a row appropriately. 
Whatever is entered for Row is the text that will appear as the Row label. These special 
rows can be handled exactly as if they are a normal row. 

Moving the row position 
After a row has been created, you can change its position by moving it up or down in the 
list. This can be important if you have created the rows in a mixed order. 

To move a row, select it, then choose Edit > Move row up or 
Move row down. You can also use the short-cut keys: 

Move a row up – Shift + Ctrl + Left arrow ! 

! 

# 

Move a row down – Shift + Ctrl + Right arrow 

Inserting names 
Names can be inserted to a row position by either typing the name manually, or by 
selecting them from the database. A single row list can contain manually typed names, or 
those selected from the database. This means it is possible to enter names to a list that 
don’t appear in the database if necessary. 

Manually entering names 
If you don’t have access to a database of names, you can enter them manually to a row 
position by clicking in the position, then typing the name. 

Names that have been entered manually are displayed as black text on a white 
background. Names inserted from the database are displayed as black text on a grey 
background. 

If possible, you should use imported data, or enter the names in Details mode. This 
makes the names entered available to other Neo applications, as well as for further 
use within NeoGroup. Any names entered manually to a row position can only be 
used for that position. If a particular individual appears in several different group 
images – perhaps a sports picture as well as a class photograph – the name must be 
typed in for each group. 

 

 

NeoGroup – Chapter 10 – Names Mode Page 68 



 

Inserting names from the database 
When names are available from the database, they can be quickly located and inserted to a 
row position. The insertion is done by starting to type the name into the Find box. 
NeoGroup searches the list of available names and displays a filtered list of names that 
match the characters entered. Choosing the name with the arrow keys, then pressing Enter 
adds the name to the current position. 

It is also possible to search using a unique ID number, meaning you can use a bar-code 
reader to create the lists. This is useful for some third party applications that construct the 
row lists, and can print a sheet in row order, along with the barcoded ID number. 

Setting the name display 
By default, when the results of a name search is displayed, all the fields defined in Details 
mode are shown. If you have many fields defined, this can mean un-necessary detail is 
displayed. 

You can control how the find results and row positions are displayed  by editing the 
program defaults. 

Choose Edit > Options > Default tab > Edit Details Fields if you want to make a global 
setting, or switch to Details mode, then choose Edit > Fields if you want to change the 
settings for this file only. 

The Data fields dialog is displayed. Choose As tags… The Details tag text dialog is shown. 

You can control exactly what details for each name are displayed in Names mode by 
entering the field and order in the box here. Fields must be prefixed by the ‘@’ symbol. 

For example, a job file has the following fields available: 

FirstName ! 

! 

! 

! 

! 

! 

LastName 
ID 
DateOfBirth 
Allergy 

Without a specific entry in the Details tag text dialog, each name displayed will show all 5 
data fields. However, this is too much detail, and can be confusing to the operators when 
selecting the names. By entering: 

@FirstName @LastName, @ID 

in the Details tag text 
box, the display is 
refined to contain only 
these three fields. 

 

After making the 
settings, choose OK 
and return to Names 
mode if necessary. 
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# If you made these settings to the Edit > Options dialog, you will also need to change 
the same options for this file in Details mode > Edit > Fields… Any new files created 
will inherit the settings from the Default dialog. 

Finding a name 
When you are ready to insert a name from the database, click the 
row required, then the position. Now, choose which field you want 
to use to search with from the drop-down box. Click in the Find 
entry box. Type the first character of the find field. You will notice 
two lists of names are displayed – those above a line, and those below a line. 

Those names above the line indicate names that 
belong to the current group folder. Those below 
the line are the rest of the names entered in the 
database. 

For example, if you are working on a Year 7 
group, all the names above the line have been 
entered in the Details mode Year 7 Folder. The 
names below the line are all the other names. As 
you enter more characters of the name, the more 
accurate the list of names displayed. 

 

Inserting the name 
Once you have entered enough characters to find the correct name, use the Up or Down 
arrow key to select the name and press Enter. The name is inserted to the row position. 
Note that nthe inserted name is displayed in a light grey background. This indicates the 
name is from the database. 

 

Continue entering names until all the positions for this row are filled. Now, choose the 
next row and continue adding names. 

Duplicate names, adding or deleting rows or inserted names 
If the same name is added to a group several times, the fact is indicated by the PC 
beeping, and the name is displayed in Red. If you see a red name, check your row list 
source and correct the problem by inserting the correct name. 
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You can add, clear or delete name positions by choosing the position, and choosing the 
appropriate action: 

 
To… Then… 

Add a position to the list Click where you want to add the position, and choose Edit > 
Insert position for name, or type Control-I, or click the Insert 
Position icon on the toolbar. 

Delete a position from 
the list 

Click the position you want to delete, then choose Edit > Delete 
name position, or type Control-D, or click the Delete Position 
icon on the toolbar 

Clear a name entered in 
a position 

Click the name you want to clear, and choose Edit > Empty 
name position, or type Control-E, or click the Empty Position 
icon in the toolbar. 

 

 
Clear Position 

Insert Position 

 Delete Position

Moving the name position 
After a row has been created, you can change its position by moving it up or down in the 
list. This can be important if you have created the rows in a mixed order. 

To move a row, select it, then choose Edit > Move name up or Move name down. You can 
also use the short-cut keys: 

Move a name up – Shift + Ctrl + Up arrow ! 

! Move a name down – Shift + Ctrl + Down arrow 

Choosing the image displayed 
If you have allocated more than one image to a group, 
you might like to switch between the images whilst 
you’re adding the names. For example, you might have one image with the subjects 
holding up a name banner acting as the key for the name row lists. 
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Switch between the images 
Choose the group you want to use, then choose View > Next group image (Control-<Pg 
Down>) or Previous group image. (Control-<Pg Up>). 

# Regardless of the image selected here, the final printed group uses the Primary 
image defined in Image mode. 
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11

esign mode 

NeoGroup uses templates to create its jobs. A template is a collection of graphic, text and 
other objects that you place into a design. When the template is chosen in the main 
application, the design is recalled, the group image placed into the design along with any 
other text and graphic objects that may be required by the template. 

Many of the objects you can place into a NeoGroup template are referenced to various 
images and text for a particular job. For example, a template can contain a graphic object 
that is the school’s logo, the Princiipal’s photograph as well as a text object that fetches 
the school campus name. When the job is run, the template fetches the school logo and 
Principal images, then the campus name for this particular job. All these elements are 
placed onto the page automatically. The result is that you can design a standard set of 
templates at the beginning of your season and use them for all your production. 

Using the template designer 
The template designer is a tool that allows you to place the various text and graphic 
objects into a design. There are no built-in graphic creation tools, meaning you must 
create all the graphics you want to use in another application like Adobe Photoshop or 
CorelDraw. 

The designer is integrated with NeoGroup. To use it, start the program, then choose Mode 
> Design. The template designer is displayed. Note that most of the available options are 
dimmed and un-available. Choose File > New to create a new template design and gain 
access to the tools. 

 

The Dimensions and units toolbar 

The main toolbar 

The Design canvas area
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The designer toolbars 
There are a number of toolbars that allow you to set various options when designing 
templates. 

The File toolbar 
The file toolbar gives you quick access to the normal File menu options. 

 
Save the currently open template 
Open an existing template file 

Create a new template 

 

 

 

The Place Object toolbar 
The Place Object toolbar allows you to place the various objects you wish to use in the 
template. There are 4 objects that can be placed into a template: 

 
Image Object Defines where the images you import in the main application will appear 

in the template. Images appear behind, on top of or inside other objects 
in a design. 

Name List object Defines where the name list will appear 

Graphic Object Defines where various graphic elements will appear in the template. 
Graphic objects created with this tool are static. Graphic objects can be 
bitmap, WMF or EMF type 

Text Object Defines where text will appear in the template. Text can be static, or 
contain a special variable ‘@’ codes. Text automatically scales to fill the 
defined text box. 

Barcode Object Defines where a barcode will appear in a Layout. Note that the barcode 
object is not available when creating a Design template. 

 

All objects, with the exception of the Barcode Object can be used in either a Layout or a 
Design template. 

To place an object, click the desired button, click inside the template canvas area and drag 
the mouse. The object will be placed into the template ready to be accurately sized and 
positioned. 

 

 
Place an image hole object Place a tagged graphic 

Place a Name List object

Place a text object 

Place a barcode object 
 

 
Place a graphic object
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The Object Layer toolbar 
Objects placed into a template can be positioned in layers, making it possible to make the 
various objects appear behind or in front of each other. 

To change the layer order of an object, select it, then choose the desired layer order button. 

 
Send the selected object to the back 
Bring the selected object to the front
Send the selected object down 1 layer 
Bring the selected object up 1 layer 

 

 

 

The Graphic Scaling toolbar 
When placing image objects into a template, you can control how the graphic is scaled 
within the object box. This is useful if you need to ensure that an image is completely 
displayed, and is not distorted. 

There are three scaling options available: 

Clip the image to fill the box maintain aspect ratio) ! 

! 

! 

Fit the whole image in the box (maintain aspect ratio) 
Fill the image in the box (distort the aspect ratio) 

The options are set using the Scaling options toolbar. 

 

 
Distort image to fill box 

Clip image to fill box 
Fit image to box 

 

Preparing and using graphic images 
There are several steps involved when creating and placing graphic objects. 

Designing the graphic object in an image editor ! 

! 

! 

Placing the graphic into a NeoGroup template 
Define any transparent areas in the graphic 

There are a number of important things you need to keep in mind when designing graphic 
images for use in a template. 

Bitmap or Vector? 
There are two quite distinct types of graphic images that can be used in a NeoGroup 
template: 
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Vector graphics from applications like CorelDraw ! 

! Bitmap images from applications like Adobe Photoshop 

The two types are completely different in both the way that they are created, and also in 
the look of the final printed image. A vector graphic is formed by drawing a series of lines, 
then applying blocks of colour to the objects drawn. The result is a graphic that is well 
suited to many logos and other design elements, but that has a cartoonish appearance 
when drawing real-life images. On the other hand, a bitmap image can create realistic 
images for use in a template. 

The big difference between a vector and bitmap graphic is that a vector is very small and 
quick to print, whilst a bitmap can be very large and slower to print. 

Bitmap file size 
If you want to use a bitmap background, you can optimise printing time by using the 
smallest background image possible. If your background has a lot of very fine detail – 
such as a fine texture – you will need to use a larger file. If the background has many 
abstract objects, or if image clarity is not particularly important, use a smaller file size. In 
general, you can use the following guide as a good starting point to determine your quality 
requirements. 

These recommendations assume a maximum print size of 8x12" @ 300dpi 

Background detail Use this file size 

Detail not important at all 2 – 4Mb 

Detail somewhat important 4 – 6Mb 

Detail important 6 – 8Mb 

Detail very important 10 – 20Mb – requires testing. 

 

Image file format 
NeoGroup offers 1 bit transparency support to blend images. This means that a single 
colour in the bitmap image can be defined as transparent in a template. For example, you 
might design the areas that are to be transparent to be white – R = 255 G = 255 B = 255. 
Any pixels in the design that have this value will become transparent. 

When saving the background image, you must use a file format that does not change this 
value relationship. For example, JPEG format will distort the white pixels close to a 
darker area in the image, resulting in ‘flecks’ through the merged image. Use either PNG 
format for compressed images, or un-compressed TIFF or TARGA images for your 
backgrounds. 

Do not use JPEG format for background images. 

Merging images 
NeoGroup allows the images you import to be placed into a design by allowing 
transparency in the background images. You design a colour that will be transparent in the 
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background image, then define that colour when the background is imported. You can use 
either bitmap or vector style graphics. Both formats allow image merging. 

Transparent areas in bitmap images 
The 1 bit transparency support means that you must carefully build-in a colour that will 
appear as transparent in your background images. First, choose a colour that you will use 
to indicate transparency – perhaps white or R=255 G=255 B=255. 

When designing the image, make sure that only transparent areas use this colour. For 
example, select the areas that are not to be transparent, and use the Photoshop (or similar) 
Levels command to limit the maximum pixel value for these areas to say R=250 G=250 
B=250. These areas will not be considered as transparent. 

 

Areas that will be transparent in the design

It is also important to carefully prepare the edges of the transparent areas in your design. 
Many image editors use anti-aliasing when placing selections. Anti-aliasing is a process 
that softens the edge of a selection, making it blend well into the image. However, this 
anti-aliasing means that the edges of your design can appear as a halo when used in 
NeoGroup. Likewise, a drop shadow effect that falls onto the transparent area will be seen 
as a halo. In the below example, a designer has created an attractive effect by placing a 
drop-shadow under a logo. This drop shadow results in a halo appearing around the logo 
in the finally formed page. 

     

Transparent areas in Vector graphics 
Vector graphics can contain areas that are a hole as a native part of their design. NeoGroup 
will reflect the hole in the design, allowing you to create transparent areas in a vector 
graphic as well as a bitmap. 

How a hole is created in a vector depends on the drawing application you are using. For 
example, with CorelDraw, draw two objects of different colour, and place them one on top 
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of the other. Choose Arrange > Combine to combine the two objects. One of the objects 
will form a hole in the other. 

Consult your applications user manual for more detailed information regarding combining 
objects for this effect. 

The Object Dimensions toolbar 
Objects placed into a template can be positioned and sized exactly using the Objects 
Dimensions toolbar. To set the size and position of an object, select it, then enter the 
desired values to the toolbar. Once done, click the Apply button to set the values. 

The Offset values set the position of an object’s top left corner. 

 
Set the template 
measurement units 

Set the object size Set the object Offset 
 

Creating templates 
Once you have all the various components, you can design a new template. Start 
NeoGroup, and choose Mode > Design. The template designer is displayed. Now, choose 
File > New to create a new template. 

Placing objects 
Once the new layout screen is displayed, click on the background page. Note that the page 
handles become active. 

When designing a layout, the actual final print size is being specified, so it is important to 
enter the correct page size. Note when the page is chosen, the Size entry area becomes 
active. First, ensure that you have the correct units selected by clicking the units drop-
down. Now, enter the page size you wish to use, then Apply. The page size changes. 

 
Figure 29: Selected background page with handles 

Placing an image 
Images can be placed anywhere in the template, and in layers. This allows you to place 
images behind and if front of one another, allowing complex and attractive images to be 
created. When an image is placed into the template, you can define the transparent area, as 
well as the size, position and image scaling options applied to the image. 
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Choose the Place graphic object button in the toolbar . The cursor changes to the Place 
Object cursor. Position the mouse over the area on the page where you want the hole to 
appear. Click and drag a box over the page. It is not important to be accurate at this point. 
A File Open dialog is displayed. Choose the file you wish to place and choose Open. 

 
Figure 30: The file Open dialog to place a graphic object 

The file is read, and the object appears in the template. Now, the Set Bitmap Mask dialog 
appears. Click the colour you wish to appear 
as transparent. In this case, we will click the 
centre white area of the background. If you 
don’t want to set a transparent area for the 
graphic, press Cancel. The graphic will still 
be placed, but no transparent areas will be 
set. 

If you make a mistake, press Reset to reset 
the selected colour. 

Once the transparent area has been set, you 
will see the transparent area indicated by the 
grid pattern. 

 

Positioning and sizing an object 
Click the object. Hold the CTRL key down if 
necessary (if several objects have already 
been placed). 

Either click and drag one of the handles, or 
drag the object to scale and position of the 
object with the mouse. If you need more 
accurate placement, click the object, then 
enter an absolute origin and size in the Object 
Dimensions toolbar, then choose Apply. The 
object is positioned and sized exactly. 
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Defining the Image Hole 
The area in your design where the images you import are to appear is called a ‘hole’. As 
mentioned before, this area is defined by colouring the areas of the graphic a 
specific colour. In this example, the area has been defined by pixels that are 
R=255 G=255 and B=255. After the graphic has been placed and positioned, click the 
Image Object button . The mouse pointer changes the Place Object pointer. Click and drag 
the mouse over the template where you want the image to appear. It is not important to be 
accurate at this point. 

When the object is placed, it will be sitting over the top of the background. 

 
Figure 31: The Image Object placed over a Graphic Object 

With the Image Object selected (the handles are visible), click the Send down 1 layer 
button. The Image Object is moved down 1 layer, and is now behind the transparent area 
of the Graphic Object. Note in the picture below that it is possible to see the full design, 
along with the whole name board. 

 
Figure 32: The Image Object placed behind the graphic object's transparent area 

Placing additional graphic objects 
As many graphic objects as you need can be placed into a template. To add a further 
object, repeat the above process. 
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# If a graphic object that is placed over the top a hole has the transparent colour, it 
will be merged is described above. Be sure that for objects that you don’t want to 
merge, you choose Cancel at the Set Bitmap Mask dialog. 

Controlling image scaling 
When placing image objects into a template, you can control how the graphic is scaled 
within the object box. This is useful if you need to ensure that an image is completely 
displayed, and is not distorted. 

There are three scaling options available: 

Clip the image to fill the box maintain aspect ratio) ! 

! 

! 

Fit the whole image in the box (maintain aspect ratio) 
Fill the image in the box (distort the aspect ratio) 

The options are set using the Scaling options toolbar. 

 

 
 

Distort image to fill box 

Fit image to box 
Clip image to fill box

 

Position and size the object 
All objects can be positioned and sized using the mouse, or very accurately with the 
Object Dimensions entries on the toolbar. Choose the object by clicking it. Note it hilights 
by showing handles. 

 
Figure 33: A selected object 
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Sizing and positioning objects with the mouse 
To re-size the object with the mouse, click one of the handles and drag it in the desired 
direction. To move the object, click and drag inside the selected object. The object moves 
as you drag the mouse. 

Sizing and positioning objects with the toolbar 
Exact size and position for an object can be specified using the Object Dimensions 
toolbar. Choose the object you wish to edit, then click the value you want to adjust. 
Pressing the Tab key switches to the next entry area. Once all the required changes have 
been made, click Apply. 

Note that the measurement units can be changed by clicking the Units drop down. 

 
Figure 34: The Object Dimensions toolbar 

 
Figure 35: An Image Object after re-sizing 

Placing multiple objects in a Template 
Templates can contain multiple objects. This means that products from simple packages to 
complex designs that include multiple graphic, text and barcode objects. 

Place several objects 
Create a new template by choosing Mode > Design then File > New. A new design is 
created. 

Place and size the first image 
Click the Image Object tool in the toolbar. Click and drag the object on the page. It is not 
important to be accurate at this point. Choose the object with the mouse, and enter the 
print size and position in the Object Dimensions. Click Apply. 
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Place the second object 
A second object can be added by following the previous instructions. You can also copy 
and paste an object by selecting it, then choosing Edit > Copy, then Edit > Paste. The object 
is duplicated. 

Choosing objects in other layers 
When several objects are placed within a template, you can cycle between objects using a 
keyboard modifier with the mouse. For example, if you want to select the background 
page that is completely covered with objects (perhaps to adjust its size), click any object 
on in the template. That object is hilighted. Now, hold the CTRL key on the keyboard. 
Note that the mouse pointer changes to the Object Cycle tool. Click the object again, and 
note that the object in the next layer below it is hilighted. 

  
Figure 36: Cycling between layer objects 

Changing the layer order 
Objects can be positioned in front or behind each other. The order of the objects can be 
changed with the Object Order toolbar. The layer order of an object can be changed by 
selecting the object, then choosing a layer order tool in the toolbar. 

 
Send an object to the bottom layer

 

 
Send an object down 1 layer

Bring an object up 1 layer

Bring an object to the top layer 

Place two Image Objects on the page, and make sure that they overlap each other. 
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Figure 37: The selected object in the top layer 

Click the Send down 1 layer tool. The selected object is sent down 1 layer, and will now 
appear behind the other in the finished print. 

 
Figure 38: The selected object 1 layer lower 

Using text objects 
Text objects in NeoGroup are a very powerful tool. Fixed text can be entered and stylised 
with font, style and colour, appearing always the same in the final printed result. Text can 
also contain variable codes, allowing a template to pick data from the job file and 
automatically adding it to the printed job. This means that you can design templates that 
can be used for all your jobs, and have them customised automatically for each client. For 
example, a template might include a reference to the school’s name, principal name, and 
even an individual group teacher’s name. When the job is run, the data is fetched from the 
database and placed automatically into the printed job. 

Fixed and variable text 
There are two types of text that can be placed in a template: 

Fixed: The text appears the same in each job ! 
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Variable: The text changes for each image according to information 
entered for the image. 

! 

Variable text is defined using an ‘@’ symbol at the beginning of the text placed into the 
template. When NeoGroup sees the ‘@’ symbol, it looks to see if it has the necessary 
information for that image, and uses it if it does. If no information is available for the 
image, the ‘@’ code is ignored. 

Placing text objects 

Create a new template – either a Layout or a Design. Choose the Text Object tool  
from the toolbar. Click and drag over the template where you want the text to appear. The 
text entry dialog opens. Enter the text you want to appear in the template. 

 
Figure 39: Text entry dialog box 

 
Figure 40: Text placed into a template 

Controlling text formatting 
Text – wether fixed or variable – can be stylised using font, colour and style. To apply 
some text styling, choose the text you want to stylise, then choose the Font, size, style 
colour or alignment from the Style Text toolbar. 

 

 Font selection drop-down Text colour

 Text size buttons Text alignment

 Font Style buttons
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Variable text objects 
NeoGroup allows various data fields be defined for the various groups in your job. For 
example, there are some things that are common to a whole school such as the school 
name, principal and so on. It is then possible to gather the school’s groups into sub-
categories. For example, the school might have a senior and junior campus. Years 1 – 7 
belong to the junior school, 8 – 12 to the senior school. You can allocate a name to both 
the campuses, and have the correct campus name inserted to the name board for each 
particular year group. 

Detail types 
As discussed in the previous chapters, Details mode and Image mode, it is possible to 
define and allocate various data fields to the folders in a job. There are three major details 
groupings: 

‘File’ details – global information such as the school name, principal 
name etc. 

! 

! 

! 

! 

! 

! 

‘Folder’ details – information specific to a folder or sub-folder such as 
the campus name, group teacher name etc. 
‘Built-in’ details – built-in information that are pre-defined in NeoGroup. 
These include the group name etc. 

In order to place the correct code into a template, It is important to understand how these 
codes are used. 

Creating a variable code 
Variable codes are inserted to a template using a special ‘@’ code. The ‘@’ code is 
inserted as normal text, including text style and colour, but contains special characters that 
identify it as text to replace to NeoGroup. 

The special code takes the form: 

@Type:’<Field>’ 

Where ‘Type’ is either ‘File’ or ‘Folder’, and Fields is any of the field names you have 
defined in Details mode. The NeoGroup built-in codes take the form: 

@code 

Where ‘code’ is the specified code as listed later. 

Using ‘File’ details 
‘File’ details are pieces of information that are common to every group in the current job. 
A File detail is set by choosing Mode > Details, then clicking All in the tree view. At the 
bottom of the Details screen, the available fields are displayed. Consult the Details mode 
chapter on information defining these fields. 

In our example, we created several fields: 

SchoolName – the name of the school 
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Principal – the name of the principal ! 

! Year – The year of photography 

 
Figure 41: 'File' details set in Details mode 

We want to create a template that will place the text ‘SchoolName – Year’ in the name 
board. The details ‘SchoolName’ and ‘Year’ are global details, and so are a ‘File’ detail. 
The codes you would enter to the template would be: 

@File:<SchoolName> - @File:<Year> ! 

 

In the above example, the printed job would contain the text: 

 Provident High School – 2000 

Using Folder details 
‘Folder’ details are pieces of information that are specific to a folder, or sub-folder in a 
job. Sub-folders of a main folder (Year 8 – 12 folders of the Senior School campus for 
example) inherit any fields defined in the parent folder. For example, you can define 
folder fields: 

SchoolType – The campus name ! 

! Teacher – A group’s teacher 

In Details mode, choose the ‘Senior School’ folder, and enter the name of the campus. 
Now, move all the Year 8 – 12 groups into the Senior School folder. Each of the years 8 – 
12 are now a part of the Senior School, and so will inherit the information typed in for the 
Senior School folder. 
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So, the group folder ‘Year 10A’ has the following details: 

Teacher -  ‘Ms. Angela Campesie’ from the ‘Year 10A’ folder ! 

! 

! 

SchoolType – ‘Senior School’ from the ‘Senior School’ folder 

In our previous example, we placed the school name and year of photography into a 
template. Now, we want to add the campus and group name. By adding the codes: 

@File:<SchoolName> - @File:<Year> - @Folder:<SchoolType>, 
@name 

 

In the above example, the printed job would contain the text: 
Provident High School – 2000 

Senior Campus, Year 10A 

Using Built-in details 
There are a number if pre-defined codes that are always available within NeoGroup. In 
Image mode we created a number of named groups. The name that is given a group here is 
the text that is used in the final job when using the @name code. 
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Available built-in @ codes 
The following built-in @ codes are available: 

@ Code Description 

Name The name of a group entered in Image mode 

 

Name list object 

Names are placed into the template with the name list object tool in the toolbar . To 
place a name list object, click the button in the toolbar, then click and drag where you 
want the names to appear. It is not important to be accurate at this point. Release the 
mouse button, and the Group Names Setup dialog is displayed. 

At the bottom of the dialog, note the sample text. This text will reflect the changes you 
make, and uses real data.  

 

Setting the Font 
Font settings are available for both the Row list Labels, and names. Choose the font, style 
and colour for both the label and names. You can choose to use the same font and colour 
for both if desirable. 

 

Set the Label font 
style and colour  

Set the row Label font

Set the Names font
Set the Names font 
style and colour  

 

Choose to use the same font
for Label and Names

Choose to use the same
colour for Label and Names

 

Setting the maximum font size 
NeoGroup automatically scales text to ensure all the names are displayed, regardless of 
each row’s length. You can define the maximum size a font will appear in the name row 
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list by setting a size in the Maximum size box. You can also choose to scale only the 
names, or both names and labels. 

 

Choose to scale names only, or 
names and labels together 

 Set the maximum font size

 

Setting the Layout 
You can set many aspects of the name row list layout. Take note of the sample text as you 
make adjustments. 

 

Control Effect 

Labels alignment Changes the alignment of the label from left, centre or right aligned. 

Names alignment Changes the alignment of the names from left, centre or right aligned. 

Labels – Names gap Changes the size of gap between the Label and Names lists 

Row-Row vertical 
extra gap 

Adjust the gap between rows 

Overall horizontal 
alignment 

Adjusts the alignment of the entire list of rows horizontally 

Overall vertical 
alignment 

Adjusts the alignment of the entire list of rows vertically 

 

# If you want to create a group image without any names, design a template that 
doesn’t include a Name list object. It is still possible to include @ codes to format 
the centre board. A group that uses this template will print without any names. 

Using barcode objects 
NeoGroup has powerful support for barcodes, making it a very flexible and powerful tool. 
Information to be encoded is included as you place the barcode as an ‘@’ code. Any 
information entered for that particular @ code will be coded into the barcode. 

For example, you might place a barcode using ‘@ID’. The fields you have set up for the 
images you import would include ‘ID’. Any information entered to the ID field will 
appear in the barcode. 
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Placing a barcode object 
Choose the Barcode Object button  in toolbar. The cursor changes to the Place Object 
icon. Click and drag the mouse over the area in the template where you want the barcode 
to appear. The Edit Barcode dialog appears. 

 
Figure 42: The Edit Barcode dialog 

There are several different styles of barcode that are supported: 

Code 39 ! 

! 

! 

Extended Code 39 
Code 128 

The Characters per inch can also be set. 

You will need to consult with the people who will be reading the barcodes as to how to set 
these values. 

Enter the text you wish to appear in the barcode in the Text to encode field. You can 
include fixed text by entering the text directly. If you want to include variable text to 
encode, add an ‘@’ code here. For example, ‘@ID’ to code the ‘ID’ data entered for an 
image. 

Tagged graphic objects 
When you design your templates, you can place a ‘Tagged’ graphic object to simplify your 
production workflow. When creating the template, you might want the current job’s logo 
to appear in the final image for each school you book. Rather than re-designing your 
templates to include each school’s individual logo, you can place a special box with a 
reference to the logo file. When you are creating the work for a particular school, you 
import the logo in Details mode. When the job is run, the logo is positioned in the design 
as specified by the template. 

Creating and positioning a tagged object 
To place a tagged object, open the template you wish to use, then choose the Tagged 

object button in the toolbar . Click and drag the mouse in the template where you 
want the object to appear. It is not necessary to be accurate. The Edit Attribute dialog is 
shown. 
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Entering the @ code 
Depending on how you create the jobs, you will have defined some default items in 
Details mode. In the previous example, we created graphic objects for the school logo, and 
the group teacher’s photographs. The ‘@’ Code is decided by the fieldname entered here. 
For example, ‘@SchoolLogo’ references the School’s logo, and ‘@TeacherPic’ references 
a group’s Teacher picture. 

Tagged graphics use the same naming as discussed in the Variable text objects section 
earlier in this chapter. Considering this naming procedure, the correct code for both these 
objects would be: 

 
Object Code 

SchoolLogo @File:<SchoolLogo> 

TeacherPic @Folder:<TeacherPic> 

 

 

Controlling Tagged graphic object scaling 
Images placed into a tagged graphic can be scaled exactly as for a normally placed 
graphic. Choose the scaling you want to use by choosing the appropriate scaling from the 
toolbar. 

 

 
Distort image to fill box 

 Clip image to fill box
Fit image to box  

Using the Tagged graphic 
Once the codes have been entered to your template, and images associated to the relevant 
fields, the graphic objects will be placed into the final job created in Form Pages mode. 

Saving templates 
Once you have designed the template, you must save it to the templates directory on the 
hard disk. The templates directory is set as a program default. Choose File > Options and 
choose the Paths tab. Now, choose the Design files tab. Enter the path to the directory that 
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will hold the templates you design. You can define more than one location for the 
templates if required. 

Any valid template files stored in this 
directory will be available to use with group 
images. 

# If you are designing new templates, you must 
quit and re-start the program before the new 
files are available to the program. 
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NeoGro
12

Form Pages mode 

Creating and printing the final NeoGroup jobs is done in Form pages mode. Here, you can 
choose the groups to print, apply templates and actually print the jobs. 

Form Page interface 
The Form page user interface consists of three main panes: 

The groups available to print ! 

! 

! 

The templates available for use 
A preview of the finished page 

 

Creating a page 
Creating a page is done by first choosing the group or groups, then choosing the template 
required. The pages are automatically formed, ready to be printed. 

If you wan to select more than one group, use the usual Windows key combinations of 
Shift and Ctrl to select blocks of groups. 
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Printing the pages 
Once all the pages have been formed, they can be printed. Choose File > Print Setup. The 
Print Setup dialog opens. 

NeoGroup uses standard Windows printer drivers to create the package bitmaps. 
NeoGroup also allows the packages to be rendered on a different workstation to allow the 
operator to continue creating packages without having to wait for the longer rendering 
process. 

When printing to a Timestone Software printer that supports long-roll paper, NeoGroup 
also automatically sets and configures the page size, meaning effective automation of the 
production process. 

Configuring printers 
Printer setup is done from the print setup dialog. Open this dialog by choosing File > Print 
setup. 

 

 

Choose the printer type: Timestone print job 
file or standard Windows print driver Open Printer properties 

dialog Choose the printer: only available if Windows
printer is chosen

File output options 
Automated print functions: only available if 

supported by the print driver. 

Index line controls 

Output file naming Output file naming 
options 

Output LUT selection 

Figure 43: The Print setup dialog 

There are three main options that can be used when printing from NeoGroup: 

Printing to a standard Windows printer ! 

! 

! 

Printing to a ‘bitmap’ style printer such as Zenographics SuperPrint 
Printing to a Timestone Print Job file 

Printing to a standard Windows printer driver 
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When using a standard Windows print driver, NeoGroup behaves in the standard way you 
would expect. 



 

Choosing the printer 
To choose the Windows printer driver, choose Windows printer from the Print to section of 
the dialog. Choose the desired printer by clicking the arrow in the Name drop-down, then 
choose the printer from the list.  

Set the printer properties 
The Windows printer properties can be set by choosing Properties from the print setup 
dialog. Once the printer properties dialog opens, follow the manufacturer’s instructions to 
set the necessary parameters. 

In particular, ensure that the page size is able to print the packages you have designed. 

When using most printer drivers, the option Pick best paper size will be available. In this 
case, it is not necessary to choose a paper size, as this is controlled by NeoGroup. This 
feature requires some configuration to function correctly. See later in this manual. 

Printing to a file 
If you wish to create a Windows .prn file instead of printing to the printer, choose Print to 
file. A file will be created for the job instead of printed directly to the printer. This file can 
be submitted to the printer at a later time. See your Windows documentation for this 
procedure. 

Printing to bitmaps 
The option Individual file for each page is used when printing to bitmaps instead of to a 
printer. See the following pages for more information. 

Automatic paper orientation 
When printing to a ‘normal’ printer, NeoGroup will automatically adjust the orientation of 
the printer’s paper to match the package being printed. Enable this option by choosing 
Automatically adjust orientation. 

Automatic orientation of a ‘bitmap’ printer 
As discussed previously, NeoGroup allows you to ‘print’ to many new digital 
photographic printers by printing its jobs to bitmap files. These files are then submitted to 
the digital photographic printer by a server software. These printers often require that the 
image be presented in a particular orientation (portrait or landscape), meaning that the 
orientation of the printed bitmap must be changed as required. 

When printing to Zenographics SuperPrint drivers, NeoGroup will print the file in the 
orientation the bitmap driver is currently set. For example, if the packages have been 
designed in a landscape orientation, but the printer driver is set to portrait, NeoGroup will 
print the image in a portrait orientation to match the driver. 

# This rotation can take a number of seconds to perform, depending on the size of the 
final print. To avoid this time, make sure you design your packages in the correct 
orientation for the printer. 
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Automatic paper size selection 
NeoGroup can automatically choose the most appropriate page size for an image being 
printed. If you have different size group images within a single file, choosing this option 
will cause the most suitable paper size be selected when printing the job. You muse ensure 
that the correct paper size is available to work exactly. 

When using standard Windows printer drivers, the physical printer must of course be able 
to automatically change the paper size to use this feature. In the main, this feature is best 
used with Zenographics SuperPrint bitmap drivers to send to a photographic style digital 
printer that can automatically vary the paper size. 

Using best paper sizes 
Choose File > Print setup… The Print setup dialog is shown. Enable best paper size 
selection by choosing Pick best paper size from the Printer options section. With this 
option enabled, NeoGroup will check all the available paper sizes, and chooses the closest 
match for the page currently being printed. This check is performed for each job, meaning 
that a queue can contain different size prints – the best paper size will be selected for each 
page being printed. 

Use custom paper sizes only 
Most print sizes NeoGroup is required to create are not standard (A4, Letter) sizes. Printer 
drivers that allow custom paper sizes to be created allow you to design sizes that are 
exactly correct for NeoPrint prints. In this case, it is not desirable to allow NeoPrint to 
automatically choose a standard paper size, as it may not be exactly correct. 

Choose Use custom paper sizes only. NeoPrint will only consider custom paper sizes when 
automatically choosing the one to be used. 

# When using this feature with the Index line enabled, be sure to allow enough room 
for the index line when defining the paper size dimensions. If the paper size is too 
small to include the index line, the next larger size will be chosen, resulting in un-
predictable results. 

 

Using printer corrections 
NeoGroup allows printer corrections by applying a LUT to the image as it is printed. This 
is especially useful if you have more than one printer in use, and you switch between 
them. It is also useful to calibrate your printer to the computer’s monitor. 

To choose a correction, click the Apply LUT drop-down box, and choose from the available 
corrections. 

See chapter 11 for more information regarding using and constructing corrections for use. 
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Print the pages 
Once all the various options have been set, choose File > Print. The print dialog opens. 
NeoGroup presents you with a list of available jobs that can be printed, and options for the 
print quantity selected. 

Choose the groups you want to print, the quantity options, then Print. NeoGroup starts 
printing the job. 

Setting the print quantity options 
NeoGroup automatically determines the number of prints to make based on the number of 
names entered for that group. You can make standard adjustments of the quantity selected, 
or you can enter your own quantity. The options are: 

Choosing Prints… 

Copies The automatically determined quantity. Type your own number here to 
manually over-ride the selection 

One only Prints one only of the page 

As indicated When enabled, the print quantity is the automatically determined 
number, plus and additional number of prints that you enter here. 

 

If printing to a file or a bitmap printer driver, specify the output path for the file. The next 
sequence number can be specified if desired by entering a number in the Next sequential 
number box. 

 

Choose the number of prints to make 

Opens the print setup dialog 

Choose which groups to print 

Over-ride the automatic print quantity if required 

Specify the output path if printing to a bitmap file 

Quick group selection keys 

Figure 44: The Print dialog 

Printing to a bitmap file 
Normally, an application uses a standard Windows print driver to print a page. However, 
some of the newer photographic digital printers will only image bitmap files. Most of 
these printers don’t have Windows printer drivers available at all. 
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If your printer is in this category, it is possible to ‘print’ to a bitmap file using printer 
drivers such as Zenographics SuperPrint™. These are a set of Windows printer drivers 
that create bitmap files instead of printing to a physical printer. These bitmaps can then be 
submitted to your printer. 

Timestone Software has also developed a number of Windows printer drivers for some of 
these photographic digital printers. 

Configuring a bitmap printer driver 
If you’re using a bitmap style driver like SuperPrint to print to your printer, you need to 
understand how your printer needs to receive the final printed bitmap files. This involves 
understanding the desired page size, and the resolution (dpi) that the printer is set to. 

SuperPrint also has some useful image enhancement features when imaging the resulting 
files to a photographic style printer. Fore more information on configuring SuperPrint, see 
chapter 11. 

Making general print settings 
Most of the settings required are identical to those already discussed. However, when 
printing to a bitmap file, choose Individual file for each page in the Printer options section 
of the Print setup dialog. With this option checked, the Output filenames settings become 
available. 

Setting the output filename options 
Choose the bitmap driver you wish to use, and check the option Individual file for each 
page is enabled. 

When printing with these settings, each page is printed to an individual file. There are 
various options available to control the filename allocated for each page. 

 

There are three options to choose from: 

A prefix: characters always at the beginning of the filenames ! 

! 

! 

! 

An image identifier: information that identifies each printed file 
Number of copies: the number of copies requested 
File extension: the image file extension 

Prefix 
The prefix is the first characters of each filename created. Each file created for a particular 
job will start with whatever is entered here. 

Identifier 
There are several options available that control the image identifier within the filename. 
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Option Description 

Image No. NeoGroup uses the image number – either the sequential or indexed number 
to name the file. If multiple packages are created, a sequential number is 
appended for each pack with the same image number. 

Original 
image tag 

NeoGroup uses the special image tag, if used when importing the images, to 
name the files. If multiple packages are created, a sequential number is 
appended for each pack with the same image number. 

Sequential 
no. 

NeoGroup creates its own sequential number to name the files. Different 
packs from the same image are gathered together sequentially, but will be 
named different one to the other. 

Copies 
The chosen number of copies is automatically entered. 

Extension 
The characters used as the file extension. 

Using printer corrections 
NeoGroup allows printer corrections by applying a LUT to the image as it is printed. This 
is especially useful if you have more than one printer in use, and you switch between 
them. It is also useful to calibrate your printer to the computer’s monitor. 

To choose a correction, click the Apply LUT drop-down box, and choose from the available 
corrections. 

See chapter 11 for more information regarding using and constructing corrections for use. 

Timestone print job files 
NeoGroup can print to a special file that contains only the instructions required to create 
the pack. This means that print times for the operator creating the job is very short. The 
print job files can then be sent across the network to another workstation, where 
Timestone Software’s PrintTime product is running. is printer queuing software, and can 
open these files directly. Once open in PrintTime, the packs can be colour corrected, the 
final quantity adjusted, and then printed. This means that the time-consuming task of 
rendering the packages can be off-loaded to an un-attended workstation whilst the 
operators continue to create packages. 

Creating a Print Job file 
Open the printer setup dialog by choosing File > print setup. Choose Timestone print job as 
the target printer. The file naming options discussed previously are still valid. Please 
review the previous section for this information. Once all the settings have been made, 
choose Ok. 

# If an Index line or printer LUT corrections are chosen when creating the TIS file, 
these settings will be applied when the file is finally printed from PrintTime. The 
Index line can be overridden, but not the LUT corrections. For this reason, be very 
careful when creating TIS files with LUT corrections. 
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Create the Print job file 
Choose File > Print. The Print dialog opens. Choose the range of packs to be printed as 
previously discussed. Specify the output path for the script file. This can be a network 
path. Choose Ok. The packages are printed. Please consult the PrintTime manual for 
further information regarding finally creating the print from these script files. 

When the TIS file is created, a matching .TIB file is also created in the same directory as 
the .TIS files. The .TIB file contains batch information for the job being printed. This file 
is used in hot folder operation, and will automatically add files to a batch when it is seen 
completed in a hot folder. 

Print Index Lines 
NeoGroup allows creating a page Index Line that can be positioned at a particular position 
on each page printed. The Index Line can contain information such as the source file, 
corrections, image number, and a number of other options. 

 
Figure 45: A page Index Line 

Printing Index Lines 

Enabling Index Line printing 
Choose File > Print setup. The Printer setup dialog is shown. Enable Index lines by 
choosing Index line on in this dialog. 

Image alignment 
Normally, if the  paper size chosen is bigger than required, the alignment of the printed 
image on the page can vary according to how the printer driver handles the mismatch. 
Using the Align setting, the image can be aligned to a specific position on the page. 

Choose the desired alignment by clicking the Align drop-down, then choosing from the 
available alignments. 

 

Configuring the Index line 
Click the Configure button. The Index Line setup dialog is displayed. 
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Figure 46: The Index Line options panel 

Setting the Index Line options 

Setting the Height 
Choose the height of the Image Line in Points. The Image Line text will be automatically 
scaled to fit within the height. 

 

Specify the gap to the Index Line 
Specify the gap amount to leave between the Package print and Index Line. This amount 
is specified as a percentage of the Index Line height. 

 

Set the Index Line position 
Choose the position for the Index Line to appear. Choosing Anywhere allows NeoGroup to 
automatically choose the most appropriate position for the Index Line. 

 

Set the text alignment 
Choose Left, Centred or right alignment for the Index Line text. 

 

Choosing the Index Line content 
There are a number of items that can be included in the Index Line. 
These options can be added to the current Index Line by clicking the 
Text options drop-down. A list of pre-defined codes appears. Choose 
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the desired code, and it is added to the end of the current text selection. It is also possible 
to enter text to the Index Line. 

 
Option Description 

Path + Filename Source NeoGroup filename and the path to that file. 

Filename Source NeoGroup filename 

Date Date the job was printed from NeoGroup 

Time Time the job was printed from NeoGroup 

Image Number Pack’s Image Number 

Image Tag Pack’s Image Tag 

Image Corrections  Colour and density corrections for this pack 

Pack Package selected 

Queue Originating printer queue 
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13

 Calibration & Color Management 
# Note: Timestone Software’s Neo family of products use the ICC color management 

system that Microsoft has built into Windows 2000. If you are using Windows 
2000, you should use the ICM-2 color management system in preference to taking 
the steps described in previous versions of this manual. 
 
ICC color management involves creating ‘color profiles’ for every display or output 
device on your system, and is considerably more sophisticated than the previous 
method. 
 
However, the ‘calibration’ method of color management, and the creation of LUTs 
(Look-Up Tables) to achieve consistent color correction is still valid if you have not 
yet upgraded to Windows 2000, and both methods are now described in our 
separate Color Management Guide, which should be available on the same CD-
ROM that this manual was on – or you can download it from our website at:  
http://www.timestone.com.au  
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